Microtik Routerboard DHCP configuration for onboarding devices to cnMaestro on premises server

Microtik Routerboard DHCP configuration for onboarding devices to cnMaestro on premises server

/ip dhcp-server option
add code=60 name=cambium60 value="'Cambium-WiFi-AP'"
add code=43 name=cambium43 value="'https://192.168.70.67'"

/ip dhcp-server network
add address=10.0.0.0/24 dhcp-option=cambium60,cambium43 \
dns-server=10.0.0.1,8.8.8.8 domain=cambiumnetworks.com gateway=10.0.0.1 netmask=24 \
 next-server=10.0.0.2

If option 43 not configured it will try for option15 in my case it is cambiumnetworks.com and user needs to map the cnmaestro.cambiumnetworks.com to the NOC Server IP in the DNS Server

If for different device models user need to configure  DHCP options, he needs to use DHCP options sets for this purpose . User needs to create different DHCP option sets where each set should contain option 60 for one device type along with the option 43 and this set can be associated with the dhcp-server network command. But to make this working user needs to also have different networks for different types of devices and each network should be associated with different DHCP option sets created initially.


/ip dhcp-server option
add code=60 name="ePMP" value="'Cambium'"
add code=60 name="WiFi" value="'Cambium-WiFi-AP'"
add code=60 name="cnPilotR201" value="'Cambium-cnPilot R201P'"
add code=60 name="cnPilotR200" value="'Cambium-cnPilot R200P'"
add code=43 name=cambium43 value="'https://192.168.70.67'"

DHCP Option sets  can be created from cli  as well as from GUI by navigating to IP->DHCP Server->Option Sets and by giving the  set name and the set options like option 60 and option 43. 


/ip dhcp-server network

set 1 dhcp-option=ePMP,cambium43


/ip dhcp-server network
set 2 dhcp-option=WiFi,cambium43


/ip dhcp-server network
set 3 dhcp-option=cnPilotR201,cambium43


/ip dhcp-server network
set 4 dhcp-option=cnPilotR200,cambium43


Now assign each set to a different network you want to assign for each device type from the Microtik Router

GUI  by navigating to IP->DHCP Server->Netwroks page.

Interface , Bridge and Port settings needs to be done prior to creating the Networks in the DHCP Server settings

Find below GUI side configuration for Network as well as DHCP options. But the options are not configurable from GUI as there is a data type error coming which is an issue with the Microtik Router. Tried with versions v6.29 and 6.3 but didn’t work. So configure the DHCP options from cli , Once configured from cli it is reflecting in gui properly.so it is adviced to configure from cli the DHCP options and then map them to the DHCP network from GUI.

Option 60 Values for other model types are as follows

 

Product

VCI (DHCP Option 60)

cnPilot R200 P

Cambium-cnPilot R200P

cnPilot R200

Cambium-cnPilot R200

cnPilot R201P

Cambium-cnPilot R201P

cnPilot R201

Cambium-cnPilot R201

cnPilot R190V

Cambium-cnPilot R190V

cnPilot R190W

Cambium-cnPilot R190W

All cnPilot E series Devices

Cambium-WiFi-AP

All ePMP Devices

Cambium

ePMP 1000 Hotspot

Cambium-WiFi-AP

PMP 450 AP

Cambium PMP 450 AP

PMP 450 SM

Cambium PMP 450 SM

PMP 450i AP

Cambium PMP 450i AP

PMP 450i SM

Cambium PMP 450i SM

PMP 430 SM

Cambium PMP 430 SM

PTP 450 BHM

Cambium PTP 450 BHM

PTP 450 BHS

Cambium PTP 450 BHS

PTP 450i BHM

Cambium PTP 450i BHM

PTP 450i BHS

Cambium PTP 450i BHS

PMP 450m AP

Cambium PMP 450m AP

Note :- No need for the user to specify the cambium id and on boarding key as by default they will be disabled for supporting zero touch on boarding using DHCP options in NOC Server  

5 Likes

What is the point of having option 60 if all device types use the same option 43?

Is including option 60 necessary for device to act on option 43? Will they ignore 43 if they don’t get 60?

Will this also work for XV wifi APs and cnMatrix switches?

Hi @VincentSupport – DHCP Option 43 is returned in tandem with DHCP Option 60 (the Vendor Class Identifier, or VCI), and both are required. The VCI for XV APs is “Cambium-WiFi-AP” and for cnMatrix it is “Cambium-cnMatrix-EX2K”.

Is option 60 required for option 15 as well?

Hi @VincentSupport – Option 60 is not needed for Option 15.