2.3.3 Release is now posted

We recently removed release 2.3.1 from our website due to a known issue around inaccessibility of the AP mgmt from a different subnet.

This issue is now resolved in version 2.3.3.

Please review the release notes and go to version 2.3.3. We will monitor the forum for any feedback.

The details are at https://support.cambiumnetworks.com/files 

I downloaded 2.3.3 and getting error message after it start initialization 

10:26:11 Error. Unpack failed - damaged or wrong package format

Pls help, Ahmed,


Sultan Ahmad,

Hi Sultan Ahmad,

I just downgraded an AP and an SM to 2.3 and then upgraded to 2.3.3 with executables that I got off of the web site.  It worked for me.  Could you try downgrading again and let me know if there was any improvement.  The error sounds to me like there was something wrong with the download.


Hi dan,

Getting same error message...i redownloaded and used a differnet browswer (safari / chrome) still the same error...this was not happening before... It was happening with 2.3.1 as well but i dnd' post anything since i noticed from the comunity that 2.3.1 had issues. 

the instruction for upgrade on the release notes PDF says that the file extention is .tar.gz and when i download it it only gives me .tar extention. 

Seems like i fixed it... Safari was downloading with wrong ext -- chrome downloaded with .tar.gz --i'm upgrading and will let you know. 

Fixed. thanks!