3000L only AP doesn't show MIR Rate on Monitor Wireless

Adding to the list of things the 3000L can't/don't do. All the 1000/2000/3000 AP's show the MIR Rate on the Montior > Wireless except for the 3000L for whatever reason.

Not a show stopper but it's always been kind of nice/handy having it there.


Honestly, i lost my hopes when they didn't "in-house" the chrome extension.

And i don't mean the code manifestation (the extension itself), but the idea, the "UX" as they say.

There certainlly is a disconnect between those doing the UI and those with the boots on the ground, and it's not exclusive to cambium....


Guys, we love feedback and how to make UI better and more useful, but please stick to the point. What we can add/improve in terms of statistics/usability? We can work here or offline if you wish.


PS On the MIR front we will get it fixed.

@Dmitry Moiseev wrote:


Guys, we love feedback and how to make UI better and more useful, but please stick to the point. What we can add/improve in terms of statistics/usability? We can work here or offline if you wish.


PS On the MIR front we will get it fixed.

Glad it's just a bug, for now it is handy to have that there.

As for improving the UI... burn it, make a new one... it's unfixable IMHO.

First, it's slow. Yes yes it sooo much faster than it was yet it's still the slowest UI around. Enter the IP of one of my Airfibers, or 450s or Canopy or Mikrotiks BOOM! Logon screen . Enter username and passsworBOOM! Interface ! When I enter the IP of a ePMP, a second maybe, banner.. maybe less than a second Logon. Enter username and password... well here is where things can get interesting because maybe it will take the username and password or maybe you need to clear your cache or maybe it will throw up a "general error" because you wasn't really talking to the radio at all. I mean, if any of those other radios are down you know INSTANTLY because the Logon doesn't BOOM! load, you get nothing.. but not ePMP noooo, it will pretend to load and then when you try to log in , think about it and then maybe general error, maybe cache, maybe something else, you just don't know with this UI. Frustrating.

Everything takes longer with the ePMP UI than any other radio... but wait, it gets worse... with the new 4x firmware you enter the IP and you get the banner... nothing, nothing, nothing... ok refresh and now banner and logon box ! Now to find out if you are really talkign to the radio, enter username and password .. and ... logon disappears then nothing, nothing, refresh Menu appears ! So you was really in the radio !! ! Yaaaaayyy... but nothing in the body of the page.. it's blank... waiting, waiting... refresh and woot now the whole interface is up ! Lucky day ! Any other radio and would be done by now but with ePMP your just now getting into the radio... or are you ? Because it can still get weird...

So you are in the radio now.. but.. why don't I have the option for TDD PTP or some frequencies are missing, how odd, is this radio really messed up ? Lets go to some ther pages in the radio, lets see hay, were is the link test ? Hmm other menu options are missing, what is the deal ? You continue to looking around the menus and things are just missing or it has options it shouldn't..

Well you force a refresh and / or clear the cache and what do you know everything looks normal now ! You was sort of in the radio but since this piece of junk UI loads the entire UI and everything gets cached , you was sort of in the radio but the UI from a previous radio running a different version of the firmware was still running so everything got all wonkey... maybe, I don't know why it does what it does I just know no other UI's I've ever worked with do this weird wrong radio UI thing.

You can bring up a ePMP interface, disconnect the ethernet so you are no longer connected to the radio and yet you can still browse through the entire UI... it's all there pretending you are still connected to the radio.. So once again, what you find out instantly with any other radio / UI takes a lot longer with ePMP. If you disconnect from any of the others and try to load a different page you can't do it ,you know instantly you aren't talking to that radio anymore but ePMP well, you have no idea if what you are looking at is current or even from the radio you think you are in or if you are in any radio at all...

The interface cheats, to appear faster, it loads the entire thing, then populates some of the data fields with ... well I don't even know where it gets the data but I can be logged into one and it will say the wireless interface is down when it clearly isn't or I couldn't be in the radio or will say the Ethernet interface is down when it isn't, or bogus IP address for interfaces for a second or three all trying to make the interface appear faster than it really is.

Oh and the floating menu ! Who uses floating menus !!? Sometimes it closes when you select the page you want and sometimes it don't.. so you have to swipe swipe swipe up to tap the little menu thing to close it then swipe swipe swipe back down. Or the thing you want, most often tools > link test is off the bottom of the screen. Now you can't swipe the menue to make it scroll, no you have to swipe the page behind it and the ratio of page moving up/down to menu moving up appears to be some random thing because sometimes the page swiped up/down half a page but the menu only moved one line! So you run out of page to swipe but the menue is still off the bottom of the screen.. so you swipe the page back to the top and try to swipe it at just the right speed to get the menu to move at the maxium amount so it will reveal the option you want before you run out of page behind it....

It is nice that after all these years Cambium finally decided to include the (%) dropped/re-transmitted on the performance page. Yet the kbps and pps are still just the total number of kbits Up/Down since the radio started seeing the client.. useful in some places but completely useless on the UI while kbps / pps would be super useful.

The througput graph, I can't even... at least the AC stuff displays the up/down bps above the frustrating graph.. How did cambium envision people using that graph ? Are we really supposed to chase those little dots across the graph trying to get the pointer to set on it before it moves so you can see what the throughput was at that point ?

If the N radios just can't display the number like the AC at least move the vertical line with the numbers on it the right side of the graph so I can what the throughput is now instead of a minute ago. Or have some horizontal lines go across the the graph so I can see where those points are on the graph without having to try to chase them down with my mouse pointer.

SA. Might be cool when you get it fixed so that it can be left on or at least doesn't take days to generate that kool graph thing that shows all the sources of RF it found that may or may not be accurate because of how long it took it to find them... Have to wonder if we really needed the expense of a second radio, doesn't Mimosa use the unused frames to sniff the air ? Do we really need to drop the connection for the closest thing we have to a site survey "Monitor Wireless" when have that second radio ?

It goes on and on and on... just a horribly bloated and convoluted UI.

1 Like

I have to agree with everything you said about the UI. It's much better than it was but still far worse compared to Ubiquiti in how it performs.

I believe there should be no caching allowed by the browser when logged into ePMP. We frequently only use Chrome Incognito mode to eliminate the weird bugs due to the page being cached. If there's a way to fix just this portion, it would perform much better.

Our techs frequently mention how they get the login screen but they can't actually ping the radio yet so they get confused if they're actually connected or not.

There is certainly room for improvement in my opinion. If the computer can't connect to the SM, there should be ZERO chance of the GUI loading when a tech enters the IP address to connect to it. Showing cached portions of the GUI is just bad for business.