4.5 Internal device error.

Looks like some of the SMs are locking up after the upgrade and need a hard reboot. They seem to still be working we just can't get into the dish also tried ssh. The login page comes up but says "Internal device error."


What devices are affected? What was the firmware you are updating from? Can you ping the device? Does it happen before or after you reboot them? Was the update done via cnMaestro our web interface?


1 Like

4.5 is extremely buggy for us, smart antenna isnt working properly. throughput graphs are broken and just a whole lot of other things.

Agreed. We've had to force all to sector usage as well. Something ain't right in 4.5

Hi russ007,

Can you show how the throughput chart is broken? What other things are causing trouble?

What exactly is wrong with the smart antenna?



I have the same problem with the force 180. The antenna works normally, but I can’t access the web interface. FW 4.5 updated via the web on the local antenna.

I upgraded from 4.4.1 it happens after the reboot. I used cnmaestro to update.

I had a force200 upgrade via cnMaestro 2.3.0 on-prem from 4.4.3 to 4.5, worked fine for a week, then got an alarm it was down, looked on the AP, it was up but we couldnt login to the web page. SSH allowed us to login once, but after trying a soft-reboot it locked us out completely. Had the client power cycle the radio and all was well again until today where it did it again. Its the only one on the network doing this.

All radios using 4.5:

One epmp300L randomly drops the ability to let SMs connect, quick reboot solves this. No particular messages from that AP in the syslog.

epmp1000 AP's

The throughput timestamps are still way out! The radios get their time via our NTP server (which is well synced) and they show the correct time/date on the home screens. Just this one page isnt showing the correct time all of the time. It will eventually show the correct information but not consistently.

Things 4.5 has fixed is the random data halts, poor throughput performance and general cpu stability (these required us to go to the tower to hard reboot the radio)

Doing an audit of offline devices in Maestro and seeing the Internal Device Error on a Force200 on 4.5 firmware. Device is pingable and can get to the login screen, but shows Internal Device Error on the screen. SM was updated to 4.5 via Maestro on 6/3/20, then stopped responding to Maestro on 6/5/20. AP is currently on 4.5.4-RC7 firmware and all other SMs are accessible. Attempted to SSH to the unit and get Access Denied when entering the known credentials. Unable to telnet to the SM. Can access the cnPilot router behind the SM without issue, but the SM itself appears to be glitched.

We have gone to 4.5.4-RC7 on all of our ePMP3000 APs due to weird reboots on the 4.5 firmware.

edit: checked the SM a few minutes later and it is now showing online in Maestro. Attempted to reboot the SM from Maestro, but the SM did not reboot or drop pings. Tried to download the tech Support file through Maestro, file did not download. Checked the login screen and still seeing Internal Device Error.

Hi Miah,

It will be great just to understand the details of the link. Is it a PTP link with a pair of Force200? Can you share a tech support dump after this unit was working for a course of couple days?


 get this on firmwares 4.4.3 and 4.5 but only on SMs. does not matter which AP type they are connected to. this seems to be triggered by a fast brown out that causes a sudden lost and restore of power. not enough to reboot the radio but long enough to corrupt the active memory. a hard reset of the SM radio is required to correct this.

1 Like