4.5R7 Config file fails to hash passwords correctly

New R190 updated to 4.5R7.  After programing the unit and saving the config file.  Using that config file to program another R190 fails to set the passwords correclty.  It is something random.  unfortuatnly I disabled the factory reset button so this first unit is bricked.  Tried on a second unit and compaired the configs and the hash is identical.  Also the hashs appear identical for all three logins (admin, user, useradmin) Anyone else seeing this?  Is there some odd defaulted password if the hash get borked?

Hi ,

If you loaded config file from router running 4.5-R7 to a router running older version(older than 4.4-R7)  you need to use encrpted characters as password instead of decrypted characters .Since password encrption was introduced in 4.4-R7 and its not backward compatible .  So on to router running  older versions  encrypted characters will be treated as plain text.

If you are still not able to login raise a request on https://support.cambiumnetworks.com/ , we will try to recover it.



So this is a fresh config pulled from a unit that had no programing.  Updated to 4.5r7 and then programed and a config file saved.  I will submit a ticket to see if we can get back into this unit.

Unfortunately, supports only solution was to RMA.  So we do need to address the underlying issue.  I can replicate this 100% of the time and it happens on both 190's and 201's.  I don't have a 200 to test it on.  The issue is that the config file appears to have an incorrectly hashed passwords.  If I do not set a password and use that config and then manually assign the password.  It works as expected.  Obviously this is not preferable.  We are not doing a very complicated config file.  I find it hard to believe we are the only ones seeing this due to how easy it is to replicate the issue.  How are bug reports best handled?

Maybe I am not understanding this well enough...but could you not add said router to cnMaestro, dump a "test" template, or any template with a useable password, into said router via cnMaestro to be able to regain access to router? 

unfortually there is no way that I am aware of to get this unit "onboraded"  I am unable to access the unit to program the cnMastro settings.

My wife scans all of our equipment into cnMaestro with this usb scanner. She then puts them on a shelve and they are "approved" after programmed and installed at customer location. 

You do not need a scanner, just type the MSN of the router into cnMaestor under Onboard > Claim device. Then find unit and "approve" it. You are then all set to dump your test template, with working password, onto router. 

So it would appear that the "$" that is in our normal password is not getting hashed correctly.  This has been escalated to engineering.  Just putting it out there until there is a fix.

The issue is that the router is not configured to talk to CnMaestro.  And we are locked out of them.  Fortunately we realized the issue only after 3 devices got bricked.

So router can not connect to the internet?