8.2.1 Firmware

I am looking to deploy 8.2.1 frimware upgrade. But first I would llike a little feedback. Has anyone Deployed as of yet? and if so, Did you run into any problems?


Works real good so far.

We have a few clients on it and seems ok so far. I’ll post again in a day or so.

Unfortunately, it seems that the 8.2 + NAT problem persists.
I upgraded to 8.2.1 and the SM crashed twice in 24 hours.
This is my log:

00:00:00 UT : 01/01/01 : File src/root.c : Line 417 System Startup
00:00:00 UT : 01/01/01 : File src/root.c : Line 422 Software Version : CANOPY 8.2.1 SM-DES
00:00:00 UT : 01/01/01 : File src/root.c : Line 426 Software Boot Version : CANOPYBOOT 3.0
00:00:00 UT : 01/01/01 : File src/root.c : Line 436 FPGA Version : 100207
00:00:00 UT : 01/01/01 : File src/root.c : Line 440 FPGA Features : DES, Sched
16:37:25 UT : 10/15/07 : File src/syslog.c : Line 1283 Time set
18:08:33 UT : 10/15/07 : File src/nibuf.c : Line 448
NiGetBuf(): Out of buffers: SrcLUID == 260
Used Bufs: 1384 Total Bufs: 3000 NoBufs: 0
Buffer Allocation:
LUID: 257 Used: 32 Max: 2048 NoBufs: 0
LUID: 258 Used: 1 Max: 3000 NoBufs: 0
LUID: 260 Used: 1351 Max: 1350 NoBufs: 0

I am very disappointed…
Anyone still has the same problem?


Upgrade non-advisable?

The “Out of buffers” crash is a new one in my experience. Hopefully motorola stays on top of it. 8.2.1 fixes a lot of other nasty bugs and you should certainly upgrade any unit already running v8 to 8.2.1. If you have v7 users, keep 'em on v7 until this bug is addressed.

BigTrumpet, hopefully you reported this to Motorola? If not, please call up tech support and get this logged.

I have the same problem with 8.2.1 NAT enable!

But, anyone of development team read the technical support case opened or this forum??

Best Regards,

Fabio Marocco

Motorola does not regularly read this forum. If you’ve got issues, they won’t come to anyone at Motorola’s attention unless you call tech support.

Just FYI.

My Network is still running flawless since i upgraded to 8.2.1

Well seem that NAT is still a problem, here goes my log

00:05:53 UT : Mon Jan 01 2001 : File src/syslog.c : Line 757 System Log Cleared
22:16:43 UT : Wed Jan 03 2001 : File src/nibuf.c : Line 448
NiGetBuf(): Out of buffers: SrcLUID == 257
Used Bufs: 2251 Total Bufs: 3000 NoBufs: 0
Buffer Allocation:
LUID: 257 Used: 2049 Max: 2048 NoBufs: 0
LUID: 258 Used: 1 Max: 3000 NoBufs: 0
LUID: 260 Used: 201 Max: 1350 NoBufs: 0

22:16:43 UT : Wed Jan 03 2001 : File src/VC_control.c : Line 864 Out of NiBufs
22:16:43 UT : Wed Jan 03 2001 : File src/VC_control.c : Line 857 FatalError()
22:16:43 UT : Wed Jan 03 2001 : File src/stack_dump.c : Line 143
Stack Dump information:
Current context Interrupt active, Task: Inet
Current Stack: 2%
Max Stack: 38%
Interrupt Stack Dump:
0x0071b9d8: 0x0001b9dc 0x0071bac0
0x0071b9e0: 0x0079a6e4 0x007194b4 0x00000bff 0x00030014
0x0071b9f0: 0x00711cdc 0x00711d9c 0x00000000 0x00000000
0x0071ba00: 0x00000000 0x00000000 0x00001404 0x02100400
0x0071ba10: 0x000aa503 0x00000000 0x00000000 0x00000000
0x0071ba20: 0x00000000 0x0071c4b0 0x000000f1 0x00001270
0x0071ba30: 0x496e6574 0x00000000 0x00000000 0x0071b9dc
0x0071ba40: 0x00000250 0x00002ffc 0x00000000 0x0000001c
0x0071ba50: 0x00000001 0x496e6574 0x00000000 0x00000021
0x0071ba60: 0x007c329e 0x00190e74 0x00532570 0x0071ba74
0x0071ba70: 0x00048f28 0x00121b78 0x00000359 0x0071bb60
0x0071ba80: 0x0005fd30 0x00000000 0x000000ff 0x0071bfe4
0x0071ba90: 0x00000001 0x00000007 0x00000018 0x009c64f8
0x0071baa0: 0x00707f04 0x009c6000 0x00060250 0x00000000
0x0071bab0: 0x0071bfe4 0x0071bed0 0x00000000 0x001dc6b8
Task Stack Dump:
0x0071bac0: 0x0071bad0 0x002c3614 0x00000018 0x0001f914
0x0071bad0: 0x00001718 0x00000018 0x00000007 0x00000001
0x0071bae0: 0x001dc6b8 0x00000001 0x002c3614 0x00000006
0x0071baf0: 0x000001ac 0x00000020 0x00000071 0x00000020
0x0071bb00: 0x00000005 0x00000039 0x0000003a 0x00000088
0x0071bb10: 0x000a8e00 0x00000029 0xdeadbeef 0x00000001
0x0071bb20: 0x00000001 0x0071bf00 0x0000000e 0x0071bd8c
0x0071bb30: 0x0000000e 0x00000001 0xffffffff 0x0000007f
0x0071bb40: 0xffffff80 0x0000007f 0xffffffff 0xffffff80
0x0071bb50: 0x00000003 0x00000001 0x000a3034 0x00000000
0x0071bb60: 0x56432020 0x32362052 0x61746520 0x32582f31
0x0071bb70: 0x58202020 0x20000000 0x00000000 0x00000000
0x0071bb80: 0x00000000 0x00000000 0x0071bfe4 0x0071bed0
0x0071bb90: 0x00000000 0x002e4760 0x00000000 0x00000001
0x0071bba0: 0x00ad9000 0x000cdc98 0x00000000 0x00000000
0x0071bbb0: 0x00000000 0x00000000 0x00000000 0x00000000
0x0071bbc0: 0x00000000 0x00000000 0x00000000 0x00000000
0x0071bbd0: 0x00000000 0x00000000 0x00000000 0x00000000
0x0071bbe0: 0x00000000 0x00000000 0x00000000 0x00000000
0x0071bbf0: 0x0071bfe4 0x0071bed0 0x00000000 0x002e4760
0x0071bc00: 0x00000000 0x00000001 0x00be0800 0x000cdc98
0x0071bc10: 0x00000000 0x00000001 0x00aab800 0x000cdc98
0x0071bc20: 0x00000000 0x00000000 0x00000001 0x0071bc64
0x0071bc30: 0x00396040 0x00ad9000 0x0002ceb0 0x00ad9006
0x0071bc40: 0x00ad9000 0x00ad9000 0x00000014 0x00024ab8
0x0071bc50: 0x0071c134 0x0071bcb8 0x0071bd20 0x00000000
0x0071bc60: 0x00000008 0x00000000 0x00000004 0x0071c134
0x0071bc70: 0x0071bcd4 0x0071bd3c 0x00000000 0x00000008
0x0071bc80: 0x00000000 0x00000004 0x0017961c 0x00000000
0x0071bc90: 0x0801aaa2 0x8a000004 0x0071bc9c 0x0801aaa2
0x0071bca0: 0xe8e8c134 0x0071bd08 0x0801aaa2 0xffffaaa2
0x0071bcb0: 0x0071bcb4 0x0017961c 0x0801aaa2 0x0020b9b6
0x0071bcc0: 0x00000009 0x00800000 0x0801aab4 0x00080000
0x0071bcd0: 0x00000009 0x0071bcdc 0x0000fad0 0x0801aa62
0x0071bce0: 0x0020b9b6 0x00000000 0x008000c0 0x0801aab4
0x0071bcf0: 0x00000618 0x00000009 0x0071bd00 0x0000fb58
0x0071bd00: 0x0801aa62 0x0020b964 0x00000029 0x00008000
0x0071bd10: 0x08018000 0xffff8000
Return Addr: 0x0011780c

I have open a case 20 days ago

I recently upgraded my older 2.4 system from sw scheduling to hw and upgraded to version 8.2 and have had nothing but problems since. I have seen a 25% loss in signal strength almost across the board and am having to redo installations which have worked fine for years. I also have customers who have great signal which are having to reboot their equipment several times a day to get things working again. Before the upgrade and switch from sw to hw I never had ANY problems with this 2.4 system.

I guess I should have followed my rule of thumb "If it ain’t broke, don’t fix it!"




I would like to give a try at 8.2.1 but I get this error in the cnut

10/18/07 09:35:50 WARN Host:;ESN: 0A003E247E40;Message: Cannot upgrade: burnfile Failed Output from Telnet session: burnflash Validating Image File: boot.image… File:boot.image is not a valid boot image Boot Image Update Failed: 11 Telnet+> ( SITE= AP-STAMB-1 )

Currently running 8.2 on this P10 AP DES

Anybody has a clue ?

Are you upgrading from 8.1.x? If so, and you have limited your snmp access, that’s probably what’s stopping you. Set the snmp filter to and 0, save and reboot. Then see if it works. I also could not accept new radios into Prizm with an snmp filter in place on

Sorry… I should have updated the thread… The source of the problem is still unknown but it looks to be firewall related… By plugging into one of our management vlans and routing via the l3 switch, I was able to upgrade 6 APs from 8.2 to 8.2.1…

No lockups yet (~28 hours) on 4 P10 APs, I also upgraded 2 P9 APs and one of those just stack dumped 20 minutes ago…

I’m suspecting I’m having similar issues to you folks…

I recently upgraded this customer to 8.2 in order to get NAPT port mapping ability for RDP ability for the customer. Today, they called and said they had no internet, and according to Prizm, things were fine…sigh The particular SM in question had been up for a little over 2 days…as 2 days ago, we installed them!

I could get to his SM (ping) without trouble…

The SM is set to, and also given a static Public IP. I could telnet to I tried to ping a few computers on his network ( with no luck. So, I rebooted the SM and after coming back up, pings worked to their network from the SM. I’m supposing this is an ethernet issue that everyone else is talking about?

I noticed all 00-00-00… for the MAC of his devices… Ignore the 12.000…that’s obfuscated.

Would this be considered the infamous ethernet issue or cabling possibility? This is the first this has happened, and this is the first customer I’ve upgraded to 8.2 from 7.3.6…The AP they were associated to is also 8.2.

One other thing. This SM is not set as a DHCP client/server. It’s default LAN1 IP is set to, vs. default of…

before reboot:

Telnet+> arp -a

IP Address Physical Address iface pend c-time l-time 00-00-24-c8-96-10 rf2 N 8886832 8887245
12.000.000 00-00-24-c8-96-10 et1 N 8859933 8859933 00-00-00-00-00-00 et1 Y 8886480 6757787

after reboot:

Telnet+> Telnet+> arp -a

IP Address Physical Address iface pend c-time l-time 00-10-18-09-29-a2 et1 N 2620 2620 00-1a-92-09-17-42 et1 N 1507 1989 00-00-24-c8-96-10 rf2 N 656 2762 1a-00-3e-91-a3-a5 rf1 N 368 376 4c-50-42-41-43-4b lo0 N 368 376


rjk, these particular issues are supposed to be resolved in 8.2.1.

twinkletoes wrote:
rjk, these particular issues are supposed to be resolved in 8.2.1.

On that information, I'll upgrade this customer's SM. thanks

I’ve getting some lockups on some 900 SM’s. The ones I’ve seen it on so far have NAT enabled, but PC’s IP"s are hardcoded. When it happens, PC"s cannot ping the LAN side of the the SM. We actually didn’t have problems with these units until they were upgraded to 8.2.1.

Here’s event log entries. Need to set time to be sure, but I think this is what happens when we get the lockups:

06:32:21 UT : 01/02/01 : File src/nibuf.c : Line 448
NiGetBuf(): Out of buffers: SrcLUID == 260
Used Bufs: 1384 Total Bufs: 3000 NoBufs: 0
Buffer Allocation:
LUID: 257 Used: 32 Max: 2048 NoBufs: 0
LUID: 258 Used: 1 Max: 3000 NoBufs: 0
LUID: 260 Used: 1351 Max: 1350 NoBufs: 0

Just to let people know I’m having trouble with 8.2.1

I’m having the same problem, except it’s not my SM’s that are rebooting but my AP, and no my AP doesn’t have nat on it.

I get a out of Nibuff’s error then it does a stack dump, then a watchdog reboot.

It happens once or twice a day.

Very frusterating, and moto support doesn’t have any answers to it.