AP on 3.4 (non GPS) can't upgrade to 3.4.1 ???


I have a connectorized AP (non GPS) with 3.4, I have tried to upgrade to 3.4.1 and it says "

16:57:34 Please perform device reboot before Upgrading software.
Clear All
I have rebooted the AP but still says the same if I try to upgrade . I have checked I'm tryting to upgrade the correct firmware
Any idea?


Could you please send configuration file in JSON format at fedor.trutsko(at)cambiumnetworks.com.
We will check what’s going on.

Thank you.

Hello roanwifi,

How many clients you have in the AP? My suggestion is to try the  upgrade without any clients in the AP. The connectorized non-GPS platform may not have enough memory available to perform the upgrade with clients registered. You can either change the AP SSID temporarily if you are using Preferred AP list in the SMs, or set the Max Registrations Allowed value to the minimum, to prevent SMs from registering, and then attempt the upgrade.




thank you for the information: disconnecting all SMs and upgrading worked!

Best regards



I have a 3.4.1 Force 2000 client radio doing this. We are trying to upgrade to 3.5 in hopes that it resolves some problems with this link.   Since the radio is the  ePTP Slave  it is the client so disconnecting clients to upgrade it isn't an option. 

Did you ever resolve this issue. I am running into the same thing with mine. 

We are having this exact same issue on a Force 200 client trying to upgrade from 3.5 -> 3.5.2.  Have rebooted the radio more than once and every time get the same message.

1 Like

Hi Larry, how did you fix this problem with Force 200?, I already read about upgrade without suscribers connected, my doubt is, how can I perform an upgrade to the suscribers remotely? If I understand well the link must be broken to upgrade succefully each device, but suscribers cant be upgraded using this method,

Any one have an idea how to do that?

Thank you in advance

Hi werever. I think that advice was for situations where someone was using a non GPS radio as an AP. So in a situation where someone was using an SM, and configuring it in AP mode, and that had a bunch of clients connected to that AP, then sometimes there’s not enough memory to do a firmware upgrade. So that advice was to disconnect the clients from the AP, and that usually frees up enough memory to successfully do a firmware upgrade.

As far as an SM which is connected as a client, we’ve never had a problem upgrading firmware over the air. We usually use cnMaestro, and just select them all and upgrade, and we’ve rarely had a problem upgrading clients over the air.

We are running in to the same issue right now with CLIENTS using 3.4.1.

Reboot the client radio and still get the same error message.  I'm going to try and use cnmaestro to do the upgrade and maybe not having the GUI open will give it enough ram to do the job. This is a total BS situation though.

1 Like

And yes, Cnmaestro is able to complete the update it seems. So, possibly the GUI is causing too much of a ram issue running it to complete these updates.