Bam License manager.

Hi there,

I’m running Redhat Ent. 3 and I’m experiencing troubles installing the licensemanager. Here’s the error I’m getting.

The installer is unable to run in graphical mode. Try running the installer with the -console or -silent flag.

And here’s the error I get when I run it with the -console flag.

The wizard cannot continue because of the following error: Invalid command line option: console is not supported (1001) (403)
WARNING: could not delete temporary file /root/ismp001/8751579

The manuals offer very litle help regarding troubleshooting. I’ve installed BAM2 itself without any difficulties.

Kind Regards

i think you missed something in the documentation saying you had to install the license manager before installing the BAM software. i couldn’t tell you exactly where i read that, but that’s what’s coming to mind when i read your post. let me know if that helps and if not i’ll sit on th eidea longer to think of other possibilities.

Nope , I was very carefull the follow the instructions to the T. I’ve installed BAM2 right afterward strait out of despirasion. I went through the code off the licensemanager and it seems that it requires the java runtime libs. Does this mean I need to run X on my linux server aswell?


I have a exactly same problem when installing License Manager part on server,
anybody know how can be solved this issue???

unfortunatelly canopy technical support not responding for my question
but I need to have BAMv2 up and running :frowning:


Are you trying the installation remotely?

The standard license manager package that you download from the motorola site requires X running to install it. Eventhough it says you can run the -console command it does not work correctly. With VNC you can run X remotely to do the install although this requires a working video card in the system.

Tech support may have an alternative to install without X, you might want to try calling them.


Thanks to Canopy support for non-X version of installer. It solved my problem and our BAM is now installed and running!