can i upgrade epmp1000non gps sync radio from software version 2.3 to 2.6???

Dear Team,

I want to upgrade  my epmpp 1000 to latest version, currently it is on ver. 2.3.

can i upgrade it directly to 2.6??

J.Satish

I upgraded a ton of non-sync radios from 2.3 (even 1.x) directly to 2.6 using CNUT with no issues.

3 Likes

Hi Satish, 

Like Josh indicated, you can upgrade any ePMP radio directly to 2.6 regardless of the software version it is currently runnig. 

Thanks,

Sriram

1 Like