Canopy, Mikrotik RouterOS DHCP problem


I have asked this question in the Mikrotik forums with no response. Hopefully someone here might be able to shed some light.

I have an Intel based RouterOS v3.20 router at the edge of our Canopy network. This router acts as our DHCP server as well. I hand out public IPs to customer routers.

I have been finding that a number of customer routers do not seem to be able to obtain an IP. I have to statically assign IPs to these problem routers. I have seen this with a number of D-Link and Belkin routers. I have not come across this issue with a Linksys router.

I have the following filters enabled in the Canopy SMs
PPPoE, SMB, Bootp Server, and IPv4 Multicast.

VLANs are used in our network.

If I were to connect the SM directly to a customer computer I often find that on the first attempt Windows fails to obtain an IP (Limited or no connectivity). If I “repair” the connection it will pick it up without any other issues.

Any thoughts?


One thing I forgot to mention is that on the APs I have the “Translation Bridging” option enabled. The AP replaces the MAC address of the client with the MAC address of the SM in ARP packets. Maybe this could be part of the issue? I was doing this so I could set the DHCP server to always give a certain IP to a customer.

Personally I would disable translation bridging and if a customer needs the same ip everytime set them as static in mikrotik itself not the customers router. then it will send out the same address to that customer everytime. we use mikrotik at every site with all kinds of different boards and have never had a problem with DHCP

Can we assume that you are running other routers between the cust. SM and the edge router, and they all have DHCP relay turned on? And, the Mtiks have the local address set to the Gateway address of the pool of real IPs assigned to that Mikrotik?

Just crossing the t’s and dotting the i’s on the basics.


Paul McCall, PDMNet
Canopy Equipment Sales and Repair Specialists
658 Old Dixie Highway
Vero Beach, FL 32962

No, Our network is bridged at the moment. Only one Mikrotik router feeding the network.

Also, we have a NetEqualizer between the router and the main switch that feeds the network.


to make sure you arent getting some rogue broadcast traffic, you should limit the broadcasts to 15 (kbps) in the QOS section of each SM. This often helps with DHCP conversations, which are broadcast like in character



I’ll give that a try.

I believe this did the trick.

Thanks for the help

You are very welcome

Paul, PDMNet