Can't upgrade or downgrade 2.4.3-RC9 radio

Was upgrading customer radios to 2.5.1 and ran into a couple that were still running 2.4.3-RC9  .   One of the radios on 2.4.3-RC9 finally upgraded to 2.5.1 after about 20 attempts.  We were trying to upgrade, downgrade, use the web interface, use CNUT, and eventually it just took the upgrade for no apperent reason.  

The other radio however...   We have tried both the web interface and CNUT many many many times because we thought that if we kept trying it would eventually upgrade like the other radio did but this radio isn't having any of that. 

  In CNUT it just fails and gives no explanation. In the web interface I get the  screen capped notification below and this in the system logs (I tried to upgrade it twice while making this post):

Oct 21 15:51:32 sheilawallace kernel: Out of memory: kill process 2476 (dnsmasq) score 46 or a child
Oct 21 15:51:32 sheilawallace kernel: Killed process 2476 (dnsmasq)
Oct 21 15:56:53 sheilawallace kernel: Out of memory: kill process 24131 (uwsgi) score 70 or a child
Oct 21 15:56:53 sheilawallace kernel: Killed process 24131 (uwsgi)

Hi brubble1, 

Have you tried rebooting the SM and attempting an upgrade? We're aware of this issue where SMs randomly fail to upgrade but a reboot helps as a workaround. 

Thnaks,

Sriram

Sriram,

   First thing we tried , and many times since.  I just rebooted it again and tried upgrading it again before I replied to you and still it will not upgrade.

This happened to to me few weeks ago, it was only on two radios (2.4.3 not sure what RC) from many, I have no idea what was diffenert on them. Only way I got them working was reset to factory default, then the update worked.

I didn't want to do a truck roll so we just kept trying to upgrade this radio over and over and finally after probably 100+ attempts it took it.