CMM Problems

I just upgrded our CMM to the latest soft. version, and sisn ce them I am havin a weird problem…the cmm just stops responding to ping & Telent requests.
All we need to do is to reset the CMM (unlpug it from the energy outlet) and it goes back to working just fine.

When I look al the system log, all I see is the “Idle web socket found” message.

Any ideas, or thoughts on this??

I’ve had the same problem with our micro. Can’t ping it, all the lights are on, power cycle it and it comes back up. This happened about a month after we upgraded to the new firmware. Still not sure what the problem was and it hasn’t happened since but we are open to any suggestions.

do you think going back to the previos software release will help?

I just found out something really weird…The CMM that is having problems is in one of our towers…and we usually had to go to the tower site in order to reset a power cycle, but this time I was able to access the cluster from an SM, and reset it using the reset command.
The funny thing is that it seems like the data port that feeds the CMM with internet gets desabled.

Any thoughts on this?

greetings amarriott!

the newest cmm upgrade introduces a new set of parameters on the Configurations menu which lets you specify an Uplink port on the cmm.

for some reason the default position seems to be that all ports can talk to one another, which is generally NOT what you would want happening.

further, we had terrible packet collisions after upgrading cmm firmware, and were only able to get to the cmm in the method you described (via an SM) as our cmm is atop a tower (don’t ask).

also, i know it was the cmm firmware as the culprit; we had not updated anything else on the network at that point.

the fix was to either enable all negotiation link speeds in the canopy, in conjunction with enabling auto sensing on each corresponding port on the cmm micro


to hard code values into each side of the link (i.e. 10 MB full duplex at the canopy AP, and also at the cmm end, as opposed to leaving one side open to auto-negotiate.
ask a router genius why that works, and he can probably tell you exactly.

but i DO love it when my customers call out of the blue the next day to tell me their service suddenly got so much better overnight.

I checked the CMM config and found out that all ports receiving AP’ were configured to 100M/FD, but the port that was receiving the internet conextion was configured to auto Negotiate.

I changed this port to 100 FD, but I still need to change the port that receives the cmm on our ain switch.
I’ll let you know how it goes.

BTW, I was looking at the option og going back to the previos soft release, bu it does not seem possible.

Any ideas…??

Going back to the previous version of software should be possible. I have downgraded SM’s and AP’s before with no problems. I’m sure Moto doesnt recommend it, but its worth a shot.

Apparently one of our instructors (Martin Keding from Manitoba) told me that in this version of CMM software update that the code has changed to (ready for this) ‘actually’ allow auto-negotiate…which should be FINE for the canopy products (APs, BHs)…


Certain non-Canopy products (can you spell C-I-S-C-O?) are famous for NOT playing the auto-negotiation game the ‘same’ as other vendors…SO…I going to guess that your system uses a non-canopy device on uplink (cisco router or switch???)…

Am I close???