cnMaestro API showing rate limiting for every request after upgrade

We upgraded from a very old onpremises version 2.3.0r28 all the way step by step to 3.1.0r1 to get the system up to date and it’s working fine so far however we are noticing our scripts are having major issues and are basically broken because whenever we send an API request their appears to be a 60 second delay between each request otherwise the API returns a error

ratelimit-limit: 0
ratelimit-remaining: -1
ratelimit-reset: 60

The next request returns…
“message”: “Rate limit exceeded”

ratelimit-limit: 0
ratelimit-remaining: 0
ratelimit-reset: 54

Is there a way to disable the rate limit as the old 2.3 didn’t seem to have that, and also on a fresh install of 3.1.0 we used to test before doing a full upgrade the rate limits were in the hundreds of requests before a rate limit would hit.