cnMaestro unable to connect

Hi there!

I've an ePMP 1000 SM on 3.4 firmware that is unable to get onboard. I'm getting this log message:

Sep  1 00:02:51 xxxxDEVICE-AGENT[5088]: rx_config_notify_cb: Send MSG_CONFIG_CHANGE_NOTIFY to cnMaestro
Sep  1 00:03:18 xxxx DEVICE-AGENT[11059]: Attempting (re)connection in 5 seconds
Sep  1 00:03:25 xxxx DEVICE-AGENT[11059]: Server certificated validation failed errno = 9, err =  certificate is not yet valid
Sep  1 00:03:25xxxx DEVICE-AGENT[11059]: Certificate is not yet valid, check the certificate host name

Some advice?

EDIT: Device home page show cnMaestro Connection Status as 'Connecting'.


Is your device trying to connect to the cloud version or on-premises version of cnMaestro?  If this is on-premises, how are you pointing the devices to your cnMaestro server?

Cloud version: cnMaestro URL =

Internet signal is ok (earth globe green). Pings to from device also ok.

Curiosly I have just checked the config, and the Cambium ID and Onboarding Key where blank. I rewrote them, saved, and they looked ok, but strange enough, won't survive a reboot! After rebooting they show blank again.

If I write ID and Onboarding Key, then save, then log out, then login, the ID field remains, but the Onboarding Key shows as blank (I have tried configuring through web interface with Firefox, Chrome and Edge with the same results).

Does this make any sense for you?

Tried this procedure and also updated to 3.4.1 to no avail.

Thanks again!

cambiumID and key becomes blank once saved , we only show on the dashboard which cambiumID is used to make the connectivity once connected.

1 Like


Turns our that:

* ePMP was statically configured, so it booted on year 2015 (hence the 'certificate is not yet valid' message).

* ePMP was configured as ePTP slave (with no master installed yet) so it seems the same problem seen in applies.

Thanks for your support!


1 Like