cnMaestro Upgrade to 2.1.0-r22

Hi,

I tried to upgrade my cnMaestro On-premise from version 1.6.3-r19 to 2.1.0-r22, but i have problems to importe the data.

The file it's uploaded correcly to cnMaestro and late in restoring proccess it's freez at 25% and doesn't do any.

We have more than 4000 devices connected and it's impossible adopt all and re-create the templates, the systems ...etc

I had the same problem as you but my backup was from 1.6.3-r39. This is what worked for me.

1. copy backup .tar.gz file to cnmaestro 2.1 server

2. ungzip backup file > gzip -d cnmaestro-export_cnmaestr_20190228T184052382875.tar.gz

3. Run import command > sudo cnmaestro-import cnmaestro-export_cnmaestr_20190228T184052382875.tar

4. Wait for progress (get coffee, bio break)

5. Wait for the reboot.

6 examine results.

3 Likes

Hi.


I have the same problem. Also, I am not Linux expert, could you please elaborate how to copy file to cnMaestro server?

Kind regards

EDIT: Looks like I am now almost Linux expert. I fugured it out. Thanks anyway.

1 Like