CnMatrix Qos by GUI

Hello,

I know that ACL works in conjunction with QoS but how to assign more priority to a MAC or IP or a VLAN?

Regards,

Hello,

QoS priority is typically applied to the switch port. However, you can use ACL to set user priority to specific host (MAC or IP) or a VLAN. Note: Dues to limited number of available ACL filters, setting priority to several hosts may not be practical.

Here’s CLI example.

Set 802.1p priority to value 5 for inbound packets in VLAN 100, and apply to all ports on EX2028:

!
mac access-list extended 1
permit any any vlan 100
!
int range gi 0/1-28
mac access-group 1 in
!
int range ex 0/1-4
mac access-group 1 in
!
class-map 100
match access-group mac-access-list 1
set class 100
!
policy-map 100
set policy class 100 default-priority-type dot1P 5 0

Set 802.1p priority to value 5 for inbound packets originated by host 10.10.10.10 and apply to all ports on EX2028:

!
ip access-list extended 1001
permit ip host 10.10.10.10 any
!
int range gi 0/1-28
ip access-group 1001 in
!
int range ex 0/1-4
ip access-group 1001 in
!
class-map 200
match access-group ip-access-list 1001
set class 200
!
policy-map 200
set policy class 200 default-priority-type dot1P 5 0
1 Like

Hello Tam,

I tried on an Ex2010-P with 4.0.1-r2 to prioritize a specific host 10.10.10.10

The int range statement is not accepted
EX2010P-Ivandesk1(config-ext-nacl)# interface ?
% Invalid Command

So I used the GUI to add the ACL extended , the class map and the policy. Traffic class 200 was “out of range” so I used 100. The outbound ports are not deleted when I press apply.

Is it correct ?

2021-10-26T22:00:00Z