cnPilot E400 2 WLAN setup, 1 direct and 2 via VPN


In my house I need 2 wireless networks, let's call them "Asia" and "Africa". All traffic for clients on the "Africa" wireless network is supposed to be routed via a VPN connection. 

I have been able to achieve this with 2 wireless routers and a Raspberry Pi. The Raspberry Pi holds the VPN client and does NAT forwarding. It also acts as DNS. Though I am not using it in my current setup, it can also function as DHCP server. The wireless router providing the "Africa" network is configured to use the Raspberry Pi as default gateway and DNS server. This setup works just fine.

I am now trying to replace the two wireless routers with one cnPilot E400. For that I've connected the cnPilot E400 with my Netgear GS110TP switch which provides LAN and PoE to the cnPilot E400. The Raspberry Pi and my provider's router are also connected to the switch. My provider's router serves as the DHCP server.

I've successfully configured the cnPilot E400 as the "Asia" network, pretty much with out of the box options with one VLAN in "zero configuraiton" mode and one WLAN on the 5GHz band. In addition I'd like to add a second WLAN that either

* Uses the Raspberry Pi as default gateway (thus routing all traffic of that network through the VPN) OR 

* Directly creates the VPN connection and provides DHCP services to the clients and thus also routes all traffic via the VPN

I've been reading the documentation about this and tried setting up a second WLAN associated with a second VLAN with the Pi as default gateway and DHCP services enabled. While that looked ok to me, my clients never seemed to be able to connect and retrieve an IP address. I've also tried to set up a second WLAN with the same VLAN, but with a tunnel configured and the checkbox to use that tunnel selected on the WLAN setup. Unfortunately that didn't work either. I've not been able to retrieve meaningful log or error messages that allow me to dig deeper.

Any word of advice, any links to documentation or other forum discussions would be much appreciated. I'll be happy to provide any information that's needed to help trouble shoot this.