cnut errors

I am trying to use cnut to update a single radio and I get this error. Message: Unable to communicate with the Network Element. Error:No SNMP response and it will not update the radio. This has been like this since I starated using 450i 900 the ap has 15.1.1 and the client has 15.0.3 The only way I can get the client radios to update is to update the ap and then it will filter down to all the clients but I do not want to interupt services everytime I add a client on the ap. The client radios are all at the default settings. I am missing something here some sort of setting I need to change but am not sure what that is. 


A couple of things

1. Make sure you are using the latest version of CNUT. There are specific versions needed for different builds. 

2. Make sure your don't have any firewalls between CNUT and the SM. Otherwise you have to open up a bunch of ports. See CNUT User Guide

If you are trying to contact an SM directly, you will need to have it be set to "Public" IP accessibility and have an IP that you can get to directly.  By default, the SM's are set to Private and have the default addresses so the management interface can't be reached from the RF side without proxying through the AP.

As far as letting the AP update the SM, it is not at all a problem to let the AP leave Auto Update enabled.  It is monitoring in the background but only when an SM comes in session and at that point it will decide if it needs to perform an update or not.  If you don't want to, or can't, setup an IP scheme that lets the SM be directly reachable, then the AP autoupdate feature is exactly how you would want to proceed.

You mentioned interrupting services - I'm interested in if you've actually seen an impact or if you may be assuming that there is since you are starting and stopping autoupdate whenever you want to perform this type of upgrade?

I am confused. I have cnut verison 4.10.5 . I have it set to enable sm auto update. But when I connect a new sm to the ap it will not auto update that sm. I have to manually tick the box to update the AP even i fthe ap is at the current version it is like the ap needs to update again in order for the auto to work and then after the AP updates it will then start the sm update process but it will not kick it off automatically I had this new sm connected to the ap for about 16 hours now and it did not auto update it. 

You clicked on the ap check box and then selected the "enable autoupdate option"?

The log window should indicate if autodupate is started.  Also, it matters what device family you are using.  What is the hardware that you are using?  PMP 100?  PMP 450?  PMP 430?   Depending on that, you will have to select the hw types that you want to support in the autoupdate configuration screen.  If you are using 450 and have 450i  or Medusa AP, these should be able to take all images and update them.  Otherwise, there isn't enough RAM on the AP (for 450, or 100) to support all of the possible SM hardware types, so CNUT will cycle through the options you select.

Can you show screencaps of what you are trying to do with respect to CNUT configuration and enabling of autoupdate?