Corrupted ESN Error with BAM1.1

I have been having an issue while attempting to add a SM to BAM. I am using BAM version 1.1 running on Red Hat EL4. I have been reading the user guide included with BAM1.1 and from what I can tell I am following the proper method and format.

I have been attempting to add a single SM. Below is the single line in my input file for the cdf formatting script:

0a003e204f63 00000000000000000000000000000000 02000200000009c4000009c40000000000000000000000000000000000000000

Per the guide, the first section is the 12-bit ESN of the SM, followed by a zeroed out 32 bit authentication string. The third section sets the uplink and downlink sustained rates to 512kbps and the uplink and burst rates to 40,000 kbps.

After this text file is created I run the cdf script as follows:
./cdf single-sm single-sm-cdf 10000 10000 10000 10000

I then upload the single-sm-cdf file to the Import Database section of the Subscriber Configuration section. I get a “Corrupted ESN” error following this. I have tried using different ESNs for different SMs and have tried using only the ESN as suggested by the thread at http://motorola.canopywireless.com/supp … 6c179e8b95.

Can you see anything wrong with what I have been attempting to do?

Thanks in advance