Edit Device Configuration Issue

When you onboard new devices where you are able to edit the device name, you are not allowed to use spaces or any special characters.  But once the device is onboarded you can use these in the device configuration.

Pictures below, if you could update the rules on the pre onboarding to allow to edit the same way you can after on boarding the device that would be super helpful.

Thank you for bringing this to our attention.  I have logged a ticket in our bug tracker for this.

The goal is to have the same name validation restrictions in cnMaestro as on the device itself and this should be universal throughout cnMaestro pages.  This might mean that space and comma characters won't be allowed, but we will check what the proper rule is when fixing this.

1 Like

I am having trouble with configuration changes with cnMaestro and cnReach. I'm using 900 MHz (ISM mode) cnReach devices in a test environment. cnMaestro is 2.1.0 with the r23 package applied.

My latitude and longitude showed up as follows on the cnMaestro configuration tab for an onboarded device (I'm not using the actual coordinates)

Latitude 50.000000

Longitude 50.000000

Obviously not a North American location so I changed the longitude to be -11x.xxxxxx and selected "Apply Configuration".

The new coordinates were successfully pushed to the cnReach device and now appear under the Main tab on the radio, but when the alarms have all cleared and device is re-registerd with cnMaestro the Lat and Long still both show up as being 50.000000. On the map this EP appears in Kazakhstan.

I have two EPs connected to one test AP. This configuraiton problem is happening with one EP but not the other one.



Could you please tell me what is your cnReach firmware version? I tested this and it worked fine.

I changed lat/lon from the cnMastro, this caused the radio to reboot, and it came back with lat/lon in sync with cnMaestro.

I also tried changing lat/lon from the radio, and I rebooted the radio, after the cnReach reconnected with cnMaestro, the lat/lon was up-to-date on cnMaestro.

The cnreach I was running was 5.2.17e.



1 Like

Hi Yonghao

I had 5.2.17d.

I upgraded to 5.2.17e and it's working now.

Thanks for your assistance.


1 Like

Hi wally1,

We tested this in 2.1.0 and verified that for cnPilot R we don't do name validations at all since we don't yet push the name to the physical device.  For cnPilot E we enforce the same naming rules for both onboarding and in the device level configuraiton page.

I just want to confirm that the same type was checked in both onboarding and at the device level in your example.  If so, then this should be fixed in the 2.1.0 release.