ePMP 2000 GPS firmware version not available.

I have the same problem and did not get it. I have to send a complaint

Hi all,

Please open new ticket with Cambium Support Team tomorrow in case Not Available is displayed on UI instead of GPS FW version.

Most likely GPS FW upgrade was terminated or finished not properly, so GPS FW recovey is required through CLI.

I will provide Support Team with GPS FW recovery from root CLI instruction today.

Thank you.

1 Like

I Fedor, I have a similar problem. After upgrading to version 3.5.1, it does not show possibilities of updating the GPS chip. I already made two powercycle but it does not unlock anything. How can I open a ticket? Best Regards


Your GPS chip is running the latest FW version AXN_1.51_2838. You don’t need to upgrade it.
Please find more information in Knowledge Base.

Thank you.

1 Like

Hi Fodor,

I've just upgraded all of our APs to 3.5.1 and am seeing the message about GPS firmware upgrade required.

GPs is AXN_3.20_8174

Can you confirm there is no known issue before I upgrade GPS?

I would rather not have to do a bunch of truckrolls and RMAs.


Hello Barry,

I can assume you are located not in APAC region, so upgrade is not mandatory required.

Please find more information on following link:


There is no known issues with the lates GPS FW, but upgrade takes up to 10-15 minutes.

Thank you.

Also having the same issue. Do I need to RMA?

Same problem here.

Can you post the GPS FW CLI instructions here?


If you have the GPS not reporting firmware version issue (showing as NA in the GUI), the GPS chip needs to be re-flashed. The procedure cannot be done from the GUI, but only as "root". Only Cambium support personnel can help you with this. Please submit a support request (go here, login and submit a request from the button on the upper right side of the page) so that a support team member can help you.



i have submitted my request

after upgrading the thing just went blank n just says gps us uptodate but nowhere to upgrade it

pretty new to cambium still learning the loops

@express wrote: pretty new to cambium still learning the loops

Well, I hate to LOL, but LOL. :)  You're new to Cambium and you've hit a pretty rare (as in, I've never heard it happen kinda rare) problem.  :)  I'm sure Cambium support will get your fixed away, and not to worry - something this serious is pretty rare.  :)

I just got the same error while upgrading from 3.5 to 3.5.6 and when tried to upgrade GPS software. The error shown was that there was a error communicating with GPS. I already contacted Cambium Support.

It does not seem so rare any more. I have two APs with this problem now when upgrading to 3.5.6... The biggest problem is that I have to be in the same subnet (with my computer) as antenna... not qul from my side, I have to drive 150km away to be able to do that.

EDIT: It did not happen when upgrading to 3.5.6. AP stopped transmiting due to a lost GPS sync and I tried to upgrade software from 3.5 to 3.5.6 so I can upgrade GPS software as well, but I can not upgrade GPS, as GPS is in "Not Available" state.

EDIT 2: I fixed one of them with taking the power out (via PoE switch) for a minute and choose Internal, so I got the option to upgrade GPS software. After upgrade everything is working just fine. :) 


You must have upgraded a sector antenna with a subscriber module firmware(NonGPS firmware)

Hi, is there still no upgrade/update for this? I am getting the message below.

On-Board GPS Chip requires a firmware upgrade. Please go to the Tools->Software Upgrade->GPS Firmware Upgrade subsection to perform the upgrade.

Version - AXN_3.20_8174

Have you tried upgrading the GPS firmware?

The GPS firmware is included inside the main firmware, so just load the same package into the GPS and see how that goes. BTW - upgrading the GPS can take a LONG time, so don't interrupt it.

1 Like

Just wanted to add that it can easyly take 10-15 minutes for the GPS upgrade. That is the reason why it is not done as a part of a regular firmware update procedure.


00:02:48 On-Board GPS Chip requires a firmware upgrade. Please go to the Tools->Software Upgrade->GPS Firmware Upgrade subsection to perform the upgrade.

×00:03:11 Initializing GPS Firmware Upgrade…

×00:03:13 GPS Firmware Upgrade in progress… Loading Firmware to On-board GPS.

×00:03:46 Error. General error of upgrade process.

Tried loading the Firmware to the GPS. 4.5.6 is what the Radio is currently on. Getting this error message now

You must hard power cycle the radio before attempting the gps firmware update. A temp work around is to go to the radio settings tab. Under the synchronization tab, select Internal(no gps). It will at least get the customers back up.

1 Like