EPMP and CNS server

We cannot discover devices that have the 2.3 firmware on them.  We are running the 1.2 CNS server.

I also want to know how the location on the map changes when we change the coordinates in the radios?

Hello Steve,

Mine seems to be be detecting them fine, I'm running version

Have you checked your scan ranges and schedule?

If you manually kick of the scan does it detect anything?

Every now and then I have my Mikrotik block my server because it does scans across the network or to many SSH sessions.

Just a few thoughts,


I have to put 2.2 on them to detect them, and then I upgrade them to 2.3.

It does show as a failed device on during the discovery, I just don't know how to see what the error is.

This only happens with 2.3 firmware.

It says failed to determine device type of xx.xx.xx..xx, discovery aborted.

Oh, maybe I was mistaken.

It looks like we just setup another client and its on 2.2, then via the console we upgrade it too 2.3.

I'll try and upgrade the next client to 2.3 before we connect it the AP and detect it with CNS.

Thanks for pointing this out guys, I am also noticing this error message in my CNS while attempting a discovery of a device with 2.3fw on it.

Make sure you have the hotfix installed and the 2.2CND files loaded, it should work. :)


2.3 devices require slightly different handling to discover them correctly.  This was addressed in the 2.2 CND files as you found.  This update is backwards compatible so you should be able to discover all supported versions of ePMP devices after using 2.2 or later CND files.

On the subject of device map locations: CNS only sets the map location of a device during initial discovery.  If you change the latitude/longitude settings directly on the device after discovery CNS won't pick up the change. 

You can either manually set the location of the device by right-clicking it on the map, delete and re-discover the device, or import a CSV file of location data via the Admin options.  The CSV file allows you to update location data en mass.


That took care of it.  I did not realize that there was a hotfix.

Thanks, Steve