ePMP version 2.3.3 error message while upgrading

I'm having a hard time upgrading my Synced and unSynced ePMP Radios from 2.3 to 2.3.3 -- getting error message below: 

10:26:11 Error. Unpack failed - damaged or wrong package format

I downloaed a few times and getting the same error msg. 

Pls help.,


sultan Ahmad,

Hi Sultan Ahmad,

I just downgraded an AP and an SM to 2.3 and then upgraded to 2.3.3 with executables that I got off of the web site.  It worked for me.  Could you try downgrading again and let me know if there was any improvement.  The error sounds to me like there was something wrong with the download.


Hi Sultan, 

Please make sure:

1. You are using the downloaded tar.gz files as-is. i.e. Do not untar the files before using them on the radio. 

2. Ensure you are using the right file for the radio. i.e. You are using ePMP-NonGPS_Synced-v2.3.3.tar.gz for the Integrated radio (the radio with two ethernet ports) and ePMP-GPS_Synced-v2.3.3.tar.gz for the GPS Sync'd radio (the radio with a single ethernet port).