Error upgrading to firmware 2.6 - 'Error while trying to read upgrade status'

Good afternoon all,

Has anyone seen this error?

'Error while trying to read upgrade status'

Current firmware is 2.5.1, I've upgraded all of my devices except this one for some reason.

I've rebooted, tried upgraded via CNS and manually via the device, tools / software ugrade and get the same error.




Hi Ryo,

Please make sure that you are using the right software image based on whether the radio is GPS or Non GPS.

Both the software can be found on the below support page.


Vivek Gupta 

We had one AP that we had to power cycle to upgrade.  It was one of the 56CE mac addresses. 

I've power cycled it a few times and still no luck, same error.

None of our AP's are GPS synced, I'm using the epmp-nonGPS_synced-v.2.6.tar...

I've upgraded our other AP's without issue, for some reason this one has chosen to be difficult.

Any thoughts? 

I did try to upgrade to 2.5.2 to see if it would take another version and got a different error.

00:38:03 Hold down "Shift" button to select or unselect range of checkboxes.
19:15:35 Error while trying to read upgrade status
19:22:37 Initializing Upgrade...

19:22:39 Error. Software upgrade/downgrade failed because device has no enough free memory. Reboot and try again.

Rebooted, tried 2.5.2 again and got the same 'Error while trying to read upgrade status'


Hello Ryo,

Would you be able to provide remote access (e.g. Teamviewer) to this device? You can PM the information to me if you can.


Got it...

It looks like the radio holds CPE information / stats and takes up memory on the AP.  (Thanks Luis)

I only had 34 clients associated to the AP so didn't think it was that big of deal, but apparently it holds enough information that I didn't have space on the AP to upload the new firmware and upgrade it.


I changed the security password, rebooted the AP, installed the new firmware, rebooted and changed the password back and everything is happy once again...

That did the trick for me.



1 Like


Thanks for the update!

Ryo is using the SM platform as AP, which has 64MB of memory, compared to 128MB of memory in the GPS Sync AP platform.


1 Like