Fix Maestro's unsolicited inclusion of third party name servers.

I understand that not every organization may run their own DNS infrastructure but when name servers are configured in Maestro either:

  1. Don't automatically include Google's DNS servers.
  2. Ask to include Google's DNS servers.
  3. Alert the user that Google's DNS servers will be automatically appended and their private DNS information may be exposed to a third party name server.

In the mean time, if anyone wants to "fix" this issue.

Zero out Google's DNS server:

maestro:~# echo "" > /etc/resolvconf/resolv.conf.d/tail

Restart networking to rebuild the resolv.conf file:

maestro:~# /etc/init.d/networking restart

Check:

maestro:~# cat /etc/resolv.conf

Agreed that vendors should not automatically add Public DNS without clear notice or give options.