Force 180 onboarding to cnMaestro

We are building a new system and recently learned of the on premis version of cnMaestro. We have been successful with onboarding our AP's and Point to Point radios. For some reason I am unable to do the same with the Force 180 subscriber radios.

Would it be possible for cnMaestro to used the GPS Lat/Lon in the radio for the location of the device in cnMaestro. I would also like to see cnMaestro discover radios on a IP range.

Thank you for the help,

Bill Lawless


WhatĀ cnMaestro Connection Status do you see on Dashboard on Force 180 CPE?

Also please check System Log where all cnMaestro debug information can be found.

It is not possible to discover radios on IP range in cnMaestro because of ePMP device initiates connection.

Today GPS Lat/Lon from device cannot be reused in cnMaestro, but it is going to be implemented soon.

Thank you.

1 Like

Thank you for the quick response. Can you give me the path to the system log file please. I have access to the shell but am not experienced enought to know where the system log would be located.

Concerning the cnMaestro connection status for the Force 180. I have been unable to onboard a Force 180 yet. The device is not listed in the Onboard queue. In the Force 180 I am running software version 2.6 and I have the cnMaestro section setup the same as on the AP's that are working. I also updated another Force 180 to software version 3.0 and had the same problem. The firmware version in the Force 180 is U-Boot 9342_PX 1.1.4.a (Jun 23 2015 - 21:37:03).

Thank you for the help,


I was able to get into the Force 180 and the command line level and found the syslog there. Here is the info after trying to onboard:

SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: SSL_ERROR_WANT_READ try again
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: Server certificated validation failed errno = 18, err =Ā  self signed certificate
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: Got 'X509_verify_cert failed' for hostname '' and certificate:
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: SSL_ERROR_WANT_READ try again
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: server's cert didn't look good 29
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: Not able to find cnMaestro, Try Discovering again
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: Discovery of cnMaestro Failed
SepĀ  2 18:40:30 Powell31#5-CPE DEVICE-AGENT[26347]: Unable to discover cnMaestro

Ā cnMaestro Connection Status is parameter on ePMP Device Dashboard.

Please verify cnMaestro URL is configured onĀ  Configuration -> System page on ePMP device GUI.

Thank you.

1 Like

From the log we see a date and time issue. We are tinking that it might be the problem. We have a firewall change to make then we should be able to use NTP.

RESOLUTION - After opening the firewall to allow access toĀ NTP and upgrading each CPE above 2.6 all of the Force 180 are now onboarding. Software version 3.0 was avalable so I upgraded each CPE to that level. They were at 2.6 or less.

I did have a CPE running at software version 2.6.2 that worked fine after allowing NTP.

1 Like

It seems not all ePMP1000 devices can be onboarded to cnMaestro, which is really unexpected surprise for me. I trusted to widely advertised advantages of cloud management for new CN products lines, and the customer whom I deliver the ePMP1000 based radio network is now rather not satisfied that I promised him what is not available in some products types.Ā 

The Force 180 5GHz radio HAS NO appropriate parameter fields to configure cnMaestro access, see the attached screenshot Force180_5GHz_no_cnMaestro.gif. The quite new Force 180 6.4GHz type has however the cnMaestro fields (see screenshotĀ Force180_6G4Hz_cnMaestro.gif).

Trying to onboard these Force 180 5GHz using their MSN numbers they are visible in the queue (seeĀ Force180@cnMaestro_vs_type.gif) in "Waiting for Device" state, however it is not clear what to do next on these Force 180 5GHz.

What is wondering me, that the 5GHz version broadly used through many countries has this limitation, but the 6.4GHz destined for limited market has no such limitation.

@Maciej JĆ¼ngst wrote:

It seems not all ePMP1000 devices can be onboarded to cnMaestro, which is really unexpected surprise for me.

Every single ePMP device we've ever had has been able to be onboarded and I'm not aware of any ePMP devices that Cambium has mentioned cannot be onboarded. Taking a quick look at your photos, you're using super old firmware. Please update to 3.5.6 and try again.


@Maciej JĆ¼ngst wrote:

...not all ePMP1000 devices can be onboarded to cnMaestro, which is really unexpected...

Hi.  I appears that you're running an OLD version of the firmware - and a Release Candidate Beta at that.  :)  There is much much newer firmware versions, so there will be LOTS of things improved and added to the newest release version. 

So, for your ePMP1000/ePMP2000 generation equipment, including ePMP1000 connectorized SM's, ePMP1000 Integrated SM's, Force180/Force190/Force200 SM's - get version 3.5.6 from here:

Note: There is also a different firmware version 4.3.1 for the ePMP3000/Force300, so you don't want to use it. 3.5.6 is what you want to use for now. That being said, the ePMP1000/2000 series (N) and the ePMP3000 series (AC2) will both have a version 4.3.2 firmware available in the next month or so I believe. But for today, download 3.5.6 for all your ePMP1000/2000 Force180/190/200 equipment, and your missing features will be found. :)

<edited> PS. I should have refreshed my screen B4 responding... Eric was already on the job!  :)

1 Like

Thank you both Ninedd and Eric for the valuable advice. I have received just few days ago a shipment from CN distributor, so I have not guessed that some devices have so old software ((2.4.3-RC16). After an upgrade to 3.5.6 everything looks ok, and now Force180 5GHz registers to cnMaestro w/o troubles. Thank you again, Regards.

1 Like

Been working for 2 days trying to get our Force180 (4.4.1 / U-Boot 9342_PX 1.1.4.h) to register onto our
cnMaestro (2.2.1-r32) on it's Public (WAN) IP Address.

Meanwhile, E410 and E430h are able to register from the same exact LAN - with absolutely no problems...

I have tried the following in the Maestro URL:
numeric IP address -

FQDN address (cnmaestro.our.domain is just an example, not actual) -

The "cnMaestro Connection Status" on the Force180 just says "Connecting"
or "Connecting in 1 minute."

I have ports 80, 123, and 443 all opened on the firewall that protects the cnMaestro server.

I have exhausted my efforts.

I need to get these units set up for Remote Control

And they need to be shipped tomorrow...

Could it be that all that have posted that it works,
are actually connecting to a LAN IP instead of a WAN IP?

Why does this work so well with all the other products, and not the Force180?


Are you able to ping cnMaestro server from Force180? Do you have separate management interface in your settings?