Force 425's are unstable

Hi i also have issue with my F425 . the uplink only stays at 30% consistent while downlink is consistent at 100%. THis are the screenshot of the link signal.

Time for another update:

I upgraded both ends of the F400C link to 5.4.2 and it dropped within a few days with the old “Reason: 53 (AP KEEP ALIVE RX STUCK)” I am now rolling both ends back to 5.4.1 and monitoring.

Recently upgraded the F425 link to 5.4.2 both ends and it has been up for 2 days so far without fault. I must say its nice to be able to set the max mcs for both directions on the SM. Latency across these links is great.

This worked in a Lab environment, around 10m separate but actual link is about 11km

Another update:

F425 link dropped for no reason after just 4 days, running 5.4.1on both ends.

I am back where I started when I posted this. Force 425’s are unstable, at least they are when running an 80Mhz channel.

I have tried 5.3, 5.4.1 and 5.4.2 on both ends. The only success I had was with the F400C when running 5.4.1 on AP and 5.3 on SM - this was stable for over 30 days. The F425 has never been stable this long. The F400C link is only 40Mhz, so this maybe why.

It is a real shame because performance is really good. But then out of the blue, for no good reason, it drops and reestablishes, dumping all my customer traffic.


1 Like

We have a F400 CSM PTP link feeding a mini pop 10 miles out running a 20 Mhz channel. When it was deployed we had a faulty F400 unit that was replaced and after It was solid but we have now started experiencing the same thing you are seeing every 3 to 5 days. The link drops reporting SM DISASSOCIATED WITH THE AP - RX KEEP ALIVE STUCK We are running 5.4.1 on both ends. Otherwise the link and performance are good, but as you noted, can’t have a link that drops out on a regular basis. Its somewhat noisy on the Master end but still getting DS9 there and DS10/11 on the slave side.
I’m not sure what the KEEP ALIVE watchdog function is, but is does not appear to be working as intended.

1 Like

We see the AP - RX KEEP ALIVE STUCK on every 400c/425 ptp link we have, regardless of firmware version or channel width. Some of these links make it only a few days at a time between occurrences and some make it a month or two.

Sep 12 07:05:38 xxxxxxxxxx-f425 kernel: [2835900.493815] SM associated with AP[bc:e6:7c:20:3a:5d]
Sep 12 07:04:55 xxxxxxxxxx-f425 kernel: [2835857.348680] wlan: [0:I:ANY] ieee80211_assoc_state_run_event: ieee80211_assoc_state_run_event: vap: 0(0x905b8000) event: 2
Sep 12 07:04:55 xxxxxxxxxx-f425 kernel: [2835857.340629] SM disassociated from AP[bc:e6:7c:20:3a:5d] F=5500 11axahe20. Reason: 53 (AP KEEP ALIVE RX STUCK)



1 Like

Wow, this issue is bigger than Cambium seem to recognise.

I have been sent fw 5.6rc9 and am trying that on the F400C link. It’s been good for a few days. It is 40Mhz though.

The F425 link is not being updated until the weekend in case bad things happen. This link drops like yours, every 3-5 days. It’s so bad. I have F425’s sitting in boxes waiting (over 12 months now) for the firmware to become stable.

Cambium is at least sending me new firmware, but why is it taking over a year from purchase to become a usable product?

I will report back on 5.6rc9


Hi @riddle,
your ticket is 359745. Right? Is there any stucks on 5.6-RC9?
I have a setup which I left on RC9 for a couple of weeks already under traffic load. I dig intentionally for memory leaks and drops to SS MCS. But still no luck to reproduce it.
I had some customers with similar cases but all were fixed by upgrade or unit swap.

Hi @Jacob_Turner, could you PM your ticket number if any or techsupport files on 5.4.2 or later right after a stuck happened?

I hereby ask all of you to PM me techsupports if you see such issue!

@aka was there a change between 5.4.1 and 5.4.2 that should help this? I have support files from at least 5.4.1 link that has dropped in the last few days I can send you if not.

Hi Andrii,

Yeah man thats my ticket number.

As mentioned, i’ve not seen the mcs bug since 5.4.1 came out. Only the link dropping issue remains for me on both F400C and F425.

F400C has been running without issue on 5.6rc9 for nearly 4 days. This link is failover for a 2GB Siklu link so, hardly ever passes traffic.

F425 will be put on 5.6rc9 in about 18 hours, as i’m waiting for the weekend to arrive. This link carries customer traffic 24/7.

Do you want support files for link drops or only for that mcs bug?


Yes, there was! I see 5 topics where memory leaks were observed during automated tests and fixes were implemented exactly in 5.4.2.
It can explain why something is rebooting once in 3-5 days. As naming says 5.4.2 differs from 5.4.1 by fixes and patches only. No new features that can break something new.

I will be grateful for both!

Keepalive RX Stuck is not a bug by itself. It just points to some event. If it happens too frequently without reason we, definitely, can find a root cause and fix it. To push it forward I need 2-3 techsupport files on 5.4.2 or 5.6. It will be a good confirmation.

The story with MCS drop to SS in uplink is turning into a ghost living its life. I’m hunting it since early 5.4.1 beta. I was pretty sure it was some SW bug. Most of customers reporting this issue did not get reproduce after upgrade to some latest builds. I had in total around 5 units which keep stuck to SS MCS in Uplinnk. It was HW failure. Compared to tens of thousands radios in production now it does not affect our normal statistics below 0.01% of HW failure. I’ve not seen it yet on 5.4.2 or later.

Now it all looks like multiple different issues. So I will continue to investigate it case by case.

1 Like

I sent support files along with screenshots at the start of my ticket, so you will find some there.

The only issue i’m left with is the constant link drops, like the others above, every 3-5 days. It concerns me that you don’t think it’s firmware causing the drops, as that only leaves hardware like you said.

I upgraded F400C to 5.6 6 days ago, and it’s been stable ever since. The F425 link was upgraded to 5.6 on Saturday, so I will monitor and report back to you. I’m very hopeful 5.6 will resolve the issue, but your mention that constant link drops are not common makes me wonder if I have faulty hardware, and maybe I should RMA rather than always waiting for new firmware to resolve it. What do you think?

1 Like

Hi Riddle,
So just to confirm… you were seeing drops every 3-5 days, and now it’s been 6 days since upgrading to version 5.6 with 6 days of uptime? That’s encouraging, so far. :+1:

To be completely accurate, the F400C link was suffering from the MCS bug, but this has not presented since 5.4.1 came out. This link runs at 40Mhz.

The F425 link was the one suffering from link drops every 3-5 days. It has been 2days 9 hours since upgrading to 5.6 and no drops yet. All other previous firmwares suffered from regular link drops. This link runs at 80Mhz.

I am hoping this disconnect issue has gone, otherwise I might RMA, in case it’s a hardware issue - I did buy the first units to arrive in my country, but didn’t deploy the F425 for over a year because the F400C was unstable, and I assumed it was a firmware issue. I deployed F425 when 5.3 came out, because I expected that would be the fw I was waiting for. I’m hoping 5.6 is the one.


The F400C now has 9 days without fault on 5.6

The F425 has 3.5 days without fault on 5.6


@aka the Reason: 53 (AP KEEP ALIVE RX STUCK) is still happening on 5.4.2. I’ll PM you some tech support files.

4 Days ago riddle said…

Inquiring minds gotta know – are we on 13 days and 7.5 days now? :smiley:

Dude we’re at;

F400C 13 days 20 hours
F425 8 days 8 hours

This is looking really good! I’m very hopeful this firmware is the one. The F425 has never been up this long :smiley:


Oh no! If that keeps up, you’re going to have to change the title of this thread!!! DANGIT! :smiley: