Getting AP430 to work on newer Cisco Catalyst C2960CX switch port


Ever since upgrading the switch that several of my Cambium radios plug into, from a C2960 to a more modern C2960CX (full gigabit and POE), the only radio that won't cooperate is the AP430.  This radio only supports 10/100 half or full.    It tries to come up on the port (where it flashes orange for a bit, then goes green for maybe 5 seconds, then repeats over and over again).   Here are  some things I have tried:

- I have upgraded to the latest firmware

- I have tried other ports on the switch

- I have ensured the switch and port config are exactly the same, which they are (after all, I just wanted to replace an older piece of hardware).

- I have tried setting 100 half and full duplex on both sides with no change - still won't come up.   I have tried auto/auto.   

- I am not sending POE (power) on the port.   I have disabled this using the  inline power command on Cisco.

The old switch works fine.   In fact, my workaround is to have the AP430 plugged into the old C2960 and then run a cable from the 2960 to the 2960CX.   It's the only way.

I am suspecting that the IOS of this new CX model introduces some functionality on the port that the radio does not like, as it is an old model.   But what?   Also, this is a gigabit model, and gigabit has more involved in the link negotiation.  Again, I have tried forcing the speed and duplex and no luck.

Please let me know if you have any suggestions .



Hi  OC, 

I do think it may be issue with the negotiation between 430 and 2960CX. It is possible  to send us  the  show lldp  and interface output, I can check on the output and see if we can help you on this. 

Also, if POE is enabled on this switch, please disable it. 


Kumaran K

Cambium Support Team


The solution here was to disable Dynamic Trunking Protocol (DTP) on the  Trunked port on the Cisco switch.   This is on by default.   The following command resolved my issue on the new C2960CX switch:

" switchport nonegotiate"

Thanks Kumar for your response.