Google Earth issue

Why is it when I clicked on the Google Earth icon and all it appeared is a notepad with some strange symbols? Previously it’s working fine…Please help?

1 Like


It looks like you have lost the file associations with kml/kmz files. The easiest way to fix it is to reinstall Google Earth.

You can set file associations manually in Windows. If you search for “set windows file associations” then you will see multiple results explaining the different ways to change the settings.



Thanks bro, I did the 2nd step and it works! :+1: :+1:


I have same problem, someone can you please let me know what to do to fix?

This fix from above should work for you too. Fix the file associations in Windows and it will work. Alternatively reinstall Google Earth.

1 Like