GPS general communication error when upgrading

i’m trying to upgrade the GPS firmware, but only gets an Error. GPS general communication error.

The ePmp AP are running 2.0.2 and have tried to restart the AP.
Not sure about the firmware on the GPS chip since i only gets GPS Firmware Version Not Available on the GPS status page.


Have you tried completely power cycling the AP i.e. removing power from the unit and reapplying it? A restart from the UI will not restart the GPS chip.

1 Like

That did the trick :slight_smile:


I really hope this is going to be fixed in a future release.

Hi j2sw, 

This has been fixed for about a year now. All you need to do is make sure you have upgraded your GPS chip to the new firmware that has the fix. Make sure your GPS chip firmware shows AXN_1.51_2838 under Monitor->GPS page on the GUI of the radio. If the GPS chip firmware version shows NA or AXN_1.51_2801, then the GPS chip is running the old problematic firmware. Follow the procedure described in the Releases Notes or User Guide to upgrade your GPS chip to AXN_1.51_2838 firmware version. If the firmware version shows NA, power cycle the unit to reset the GPS chip and then perform the upgrade.