GPS inconsistent on one AP

I have an ePMP1000 GPS AP (2.4ghz) which is actually the first ePMP AP we deployed.... over 2 years ago at least.  it's been working fine, we are the only provider on this building top - so the nearest interference should be on the next building at the closest - and that's the block over.  In any event, last week the GPS lost link (which disconnected the clients of course) and we rebooted and no change.  I upgraded the firmware to 3.5.2 RC15 and when that booted up, the GPS was back - with SNR's in the 40's

It's gone away a few times since, and no - I haven't yet tried disconnecting the external puck.  And no - I haven't yet tried replacing the AP with another unit.  it's quite a climb and I'm trying to get a feeling for what the likely culprit this is before I start changing hardware.

This is the GPS Monitor right now - with 0 tracked satellites.



And this is a screen shot of what it normally looks like.  Then it suddenly goes to 0, and only in the last week.

GPS_No_Issues_May_2018.jpg

There is (AFAIK) no new interference, no weather changes, no water in any connector.

The good news is that this AP is all by it's lonesome as far as 2.4Ghz Synced AP's, so we can switch it to INTERNAL and not really see any performance hit to anyone.  But, I'd like to figure this out  and see if there's a way to narrow down and to diagnose what's going on.