GPS sync oddity

Spent the last hour doing some firmware testing. The three 2000's that are working are on 3.5.1. The one that wasn't is on 4.3.3. Downgraded to 3.5.6 twice to get all banks on the same FW. No change in GPS. Downgraded to 3.5.1 twice. Still no change in GPS. Not sure if this puck crapped out or what.

According to Packetflux the problem affected a specific revision of  GNSS modules and the company that they get them from ran a simulation to confirm it was caused by the GLONASS rollover.  It's possible the same revision of these modules (unless they are patchable) will glitch again when the 2023 rollover comes around.

For 99.9% of the modules affected just power cycling / rebooting them fixes the problem.

1 Like

I guess I'm in the 0.01% then because multiple reboots over the past week have done nothing,.

I had another interesting turn of events this morning. Around 4am PST, I lost GPS on another sector on the same tower. Rebooted it a couple times, made no difference. 0 of 0 satellites. Had to set timing to internal to get customers back up. And since that happened the one that hasn't worked for the past week is now showing 12 of 17 satellites tracked. I haven't been able to test the GPS as we are in business hours, it's still set to internal.


Did you reboot the AP from the software or actually switched the power off and back on? Also as a general recommendation that is not directly connected to original issue please disconnect the external GPS puck.


I've done through software and by disabling POE on the switch port. As of right now all of my GPS is working. It came back on its own during the day yesterday and I was able to enable GPS overnight.

Lost GPS agian this weekend. I opened a ticket.