Help on ePMP when on Router mode

Hello everyone and thanks for looking at my post. I hope someone might be able to help me out or give me an idea to try.

I am trying to get the ePMP 1000, setup for a Subscriber Module as a router mode, we want to prevent loops on or networks when these radios go haywired.

I want to add that I was able to get the NAT mode to work perfectly and get internet connectivty and browse the internet with the SM being in NAT mode.

But anytime I put the SM on Router Mode, It will not give me a network connection. I see from the AP and the SM that both have internet conectivity, But the PC that I plug the SM into directly for testing does not get a Internet connection, it does happen to get a Network Connection, but says no Internet connection on the network settings on the computer device.

I double made sure my configurations were correct on the AP and put the SM on Bridge mode, and was able to get the SM to connect to the internet and the computer device to get internet through the SM. As well I was able to do this when putting the SM in NAT mode.

Is there something I am missing when I am setting up Router Mode for the SM? The NAT mode is about the same as Router mode, but router mode has static routes you can setup and you can setup ip aliais. I have fiddled and tryed playing around with as many settings and configurations as I can think of, but for what ever reason, I cannot get this SM to work in Router Mode and provide a Internet Connections to the Computer. 

I don't know if it was because I was trying directly from the PC, maybe I have to have the SM hooked to a router or a switch. I haven't tried that yet, but I dont see how that would make a difference. 

I am able to get the Ethernet Interface setup and do DHCP on it and even turn the DHCP off and configure it and with advance settings I can tell the SM to get the DHCP above the SM. 

If anyone has a helpful setup guide on how to configure these SM in router mode! I would be most greatful and or any ideas.

Thank you all so much.

Need a little more info. When you put the SM in bridge mode (and it works) do you manually set a static IP info on your PC's interface or do you have it configured to get that info from a DHCP server ? 

If your PC works in bridged mode then when you set the Radio to router mode you need to configure the network mode to be exactly what your PC was set to .

So if you configured static IP info on your computer then you need to set the Wireless interface on the SM to Static and enter the IP information that was working on your computer. Then set your computer to accept IP info via DHCP  and configure the Ethernet Interface on the radio with a local IP and enable DHCP, set a start/end IP and enter the DNS servers. Or set a static IP on your PC that is in the same subnet as the IP you put on the SM's Ethernet interface (but not inside the DHCP range if you enabled DHCP)

If your PC was getting IP info via DHCP then you when you set the SM to router mode set the Wireless IP Assignment to DHCP instead of Static. Then configure the Ethernet on the SM and your PC the same as the above.

Otherwise, need to know more info about your network, what addresses you are using, how the addresses are assigned to devices, is the AP also in bridge mode ? etc..

Also, depending on how you are controlling your customer's access you can use bridge mode and the SM's settings/firewall to prevent them from causing any problems (like plugging their router in backwards so it is trying to DHCP address to everyone on your network).

Hi brubble1,

Sorry for the late reponse, been kind of busy with the network lol. 

So, here is what I am doing,

I setup the SM in router mode: with static address assignment, (I also tinkered around with putting it on DHCP to see if that would work better but did not.)

In the SM configuration General section:
Network Mode: Router

Wireless IP Assignment: Static
Wireless IP Address:
Wireless Subnet Mask: /24:
Wireless Gateway
Alternate DNS:
Ether port Security: Disabled

Ethernet Interface:
IP Address
Subnet Mask:
DHCP Server Enabled.
DHCP Start:
Alternate DNS:

Separate Wireless Management Interface: I have this turned on because if I don't than for what ever reason I cannot remote into the SM, when it comes up on the AP. With this on, I am able to remote into the SM from another PC.

This is setup in the following:
Seperate Management IP: Enabled
IP Assignment: DHCP
It gives
Subnet: /24

I don't have VLAN so all that is disabled and on the AP. 
Static Routes: Disabled
IP Aliases: Disabled

This is the current setup, when the SM starts talking to the AP, it shows on the SM, that it has internet connectivity, but will not provide the computer I am bench testing this with to get Internet Access.

From what I read from you and understanding you mention that I have to setup the Computer with the Static IP address as the same what is staticly configured from the Wireless IP assignment? 

I appreciate all your help brubble1 and I hope we can get this working.

That setup won’t work, you’ve got the same subnet on both wired and wireless interfaces on the radio. Change one of them to another lan block or shrink both subnets.

Easiest to change the lan side to 192.168.2.x and it will work.

Otherwise flip your radio to bridge and let that single plan pass through it.

Hi Chris_Bay,

Thank you for your reply, I will try this out and let you know how the results turn out. Thank you again.

Hi Chris_Bay,

I tried this and changed the LAN side (ethernet side) to 192.168.2.x and this did not work, I am still going to tinker with it but if you have any other ideas or solutions I will try them. Thank you again for your help.


 When you put the radio in bridge mode and your PC works exactly how is the networking on your PC configured ? 

can you post more of your config?  the devices you want to interact with this link too.   when your running in router mode, there is a lot more going on than with just the epmp radios.  the other routers involved will need to know how to reach the subnet on the lan side of that radio, if you've disabled static routes, how are you reaching them?    the epmp radio will need to be aware of other routes in your router as well. 

I am bench testing this at my house, I have an AP hooked to my network and I have the SM so they can talk to each other. I put the SM on router mode and I placed the Wireless Interface on DHCP and I put the Ethernet Interface and set it up as you instructed, and my computer gets the DHCP from the ethernet interface. But not Internet Connection, it gives me the LAN but no internet. What is strange is that I can put this in NAT mode and it will work.

I would not expect that to work as yoyou described. Your router doesn’t know about another lan beyond the epmp radio. It would need to know that behind node 192.168.1.x lies network without router 1 knowing that, it can’t talk to a host on lan2 or ththe internet. With nat enabled it doesn’t actually talk to lan2, the epmp radio translates and interacts with both sides on behalf of the other.

When in router mode, it only passes the packets rather than relaying the conversation.

To make router mode work, in your home router, define a static route to to the lan ip you gave the epmp radio, then you’ll get access to lan 1. You may need to define additional nat rules for lan 2 to enable internet access.

Let's assume such network topology:

So you need to do extra configuration on the router. If the router is using Ubuntu OS then run:

sudo route add -net netmask gw eth0
sudo iptables -t nat -A POSTROUTING -s -o wlo1 -j MASQUERADE