Interesting Statement from Keith R. Parson Wi-Fi Pro at Ekahau Wi-Fi Design Day in Munich June´19

Very interesting statement from Keith and I happen to agree with him based on a relatively recent experience of mine.

I enabled RRM (Auto RF on cnPilot devices) and left the settings on default.

While monitoring this network I could see that on occasion devices where connecting to APs with higher RSSI values. At first I assumed it was sticky clients not roaming properly however when I looked into the events tab I could see that APs were changing channel in the 2.4GHz frequency due to detected interference / high rates of packet errors.

It turns out some client devices we're not reconnecting to the new channel and were selecting another APs despite their weaker signal. I turned off Auto RF and the problem was solved, clients would connect to the best AP. 

I need to investigate what was the cause of the forced channel change was before I adjust and re-enable Auto-RF. But for now the network seem to working well and the users are happy.