Issue when upgrading an AP to the 12.2.2 from 12.1

After having updated all the SM with the current versions of CNUT on linux (4.6.9) from version 11.2 - 12.1 - 12.2.2, I can’t do the same with the AP
I also have tested the upgrade on windows CNUT with the same error.

What I am getting is basically

Transferring Files 57_20_o120.imt ot host …
Failed to enable update, Error Code: 21-NotWritable

I have verified that my ip is in the field “Update Application Information” just in case.

Any tips on this issue?


Can you provide more detail? This is a PMP 430 AP that you are unable to update, correct? Is the AP a DES version or an AES version? In CNUT, do you have auto-update enabled?

Finally, if you reboot the AP and try the CNUT upgrade again, does it successfully upgrade the PMP 430 AP.

It’s the DES version, I have manually updated the SM (about 10 of them), I don’t have autoupdated selected.
I have tried during several days and after rebooting quite a lot of times (I am checking for a better radio freq.)


Can you verify that the SNMP settings on the AP? On the PMP 430 AP, is the SNMP Community String set to Read/Write.

I have the same problem on windows 8.1. I am connected to the SM back to back setting SNP to

I got "Failed to upload file 57_20_zo55.img, Software caused connection abort: socket write error" while upgrading from 12.1 to any of the later versions.

I am using PMP 430 SM, CNUT version 4.5.3 and the latest version showed the same error, too. Does anybody has a solution?

Could you verify that you PC/Laptop’s firewall is not blocking port 80 from an inbound and outbound type of connection?

We have had customers who disabled their anti-virus/firewall and attempted the upgrade with CNUT again, and it worked fine. Socket write errors are typically due to the device closing the socket. A way to troubleshoot this is to run Wireshark while trying to upgrade/update a radio.