Latency Issues

Hello all!
I’m hoping to get some insight on the issues we are having, I’ll try not to rant or give useless info. We are running a canopy 900MHz network with 6 AP’s at this point, all using mikrotik for routing. we recently changed upstream providers as we thought that was our issue. we were running on a DSL backbone using an adtran, now we are on a fiber backbone using a Mikrotik as an edge router (not sure if your supposed to be able to do that but we have), we made the switch over the course of a couple of weeks and finally last week made our final server changes Name servers mail servers and all that jazz. we had some issues with dns but it looks like that has been resolved, we are now seeing high ping times from both the customer SM’s and from our main link to others (not sure if that seems vague) for instance, we can log into a mikrotik from at one location and ping another mikrotik and get fine results, no more than 10 MS but if try to ping the same tik from our office we get erratic spikes up to 300 MS! we thought it may have been an interference issue with our main link so we went from a 10mbps trango link to a 20 canopy BH yesterday but are having the same issues. i’m not sure if thats all the info someone would need or not feel free to email me or pm me with anything you may need to know, i’m new to the Wisp industry and have used this forum quit a bit to learn as much as i can i’m currently just a road tech but i deal with customers and would like to know what i’m talking about

Thanx in advance for any help
Eric ATItech

Have you run a link test from your backhaul? Any ethernet errors on any of the interfaces on either backhaul, switch, router etc.?

Link test’s on the backhaul’s are good the only thing i see is a jitter of 7-8 but at 2x we would think thats fine. ethernet errors have shown up (in side on the backhaul’s both slave and master but slave has more) what would cause that? i would attribute that to the cause but we had this problem before we changed from trango links to backhaul’s but i would like to get that resolved… is there a good way to check for errors on a switch? we thought it might have been the one we were using so we changed it with no change but that is something i would like to know just in case… thank you for the reply we are just at our wits end with this and we would just like some fresh thought and ideas thank you all very much for just looking at it

The most common cause for ethernet related problems would be cabling.
1. Make sure you are using Outdoor Cat5E SHIELDED Cable at both sites.
2. Remove any inline surge suppressors/lightning protection etc. for troubleshooting.
3. Hopefully you are using managed switches at both ends… force both backhauls and switch port interfaces to 10M/FULL and see if error counters stop incrementing.
4. Are there any FM Radio Stations within close proximity to either tower? FM Radio Stations can cause this problem also, as they transmit near 100MHz. Ethernet at 100M runs at 100MHz.

Thanks again, okay edit from last post there is no 2x i had just assumed i guess, outdoor cable isn’t shielded from what i know, hasn’t been a problem before i don’t think but we will look into it, we don’t have a surge suppressor at the office site yet but we do at the tower site, we used it as a line extender at the tower site so we can’t really test that yet, no managed switch at the office or the tower but we have changed both BH’s to 10mfull we are waiting to see if that makes a change fm radio stations are not an issue we have seen before so we are ruling that out, this infrastructure was already in place what we have changed are servers, changed from trango link to BH, and are using a mikro tik instead of an adtran for edge core router, we have a consultant comming in today who is familar with canopy and mikrotik hopefully it will be something stupid other than the ethernet errors, but we would like to get the resolved as well
thanks again for responding

Replacing the cable may or may not resolve the issues, but it is always best practice to use Shielded Cable at the tower site. Here is some info about the cabling that we use:

Mohawk Cable

Just a note about the duplexing: Auto negotiation defaults to half-duplex if there is no actual negotiation. By setting your BH ethernet to 10/Full you are stopping the auto negotiation protocol. The switch on the other end has no idea what the link should be at, so as per the standard will fall back to 10/Half operation.

Do you have any update on what the problem was. I am just curious for my own knowledge on what you found out.


Sorry about the long wait things got very crazy a day after my last post and i havn’t been able to check the forums like i want to because i’ve been training a new tech :slight_smile: thanx for being curious, so i’ll try to give you a run down over the mass amount of changes we have made and what we are seeing now.

1. First thing we did was change our main link from regular outdoor to shielded cable Result: errors gone yay!
2. then we had a link start going really stupid, this was a bad link setup to begin with. without going through our link setup (as i assume you don’t really need to know that) we took that link out and replaced it with a shorter shot from one of our newer towers to one of our older ones, big difference there! also is something does go wrong there i’m am only 20 mins from the tower and can get there very quickly from my house. so we decided that we hate trango and finally got the boss man to invest is some BH20 now we only have 2 trango links left and just waiting to get those switched all in all we basically changed a good amount of our link setup and saw a lot of dramatic changes right from the get go… and we don’t throw up if we have to reboot a link (trango’s don’t like to come back up with opmode on :frowning: so things have gotten better and i’ve conviced my boss to let me change all of our cable to shielded and I will be doing regular tower maintenance (new guy will be the new road tech)

so i can basically say that things look a lot better and i really appreciate your help you really pointed me in the right direction…

with that said i will be starting another post please check that out maybe you can help me out there too :slight_smile:

Thanks again

Glad to hear that replacing the cabling has resolved your issue :slight_smile:


If you ping the trango backhauls while they are booting up they will switch to opmode off. I’m not sure if this is the problem you are having but i hope it helps.