lldp snmp broken?

I only recently noticed that the Layer 2 neighbors tab is blank on all my devices, and i checked and the adjacent devices have lldp enable to send...

When i checked the standard spot for lldp in the mibtree isn't getting populated at all, with the recent fix to System name being sent from the 450's in 15.2 i finally started looking more into what was working/wasnt and ran into this

Not sure how long its been like this but in 15.2 and 15.1.5 this screen shows blank.

I've verified it on 15.2. We do display "Layer 2 Neighbours" info.

I've verified on few different SW versions, all the way back to 15.1, and it seems to be working fine on all of them.


Could you please ensure, in "Configuration->General" page, under "Layer 2 Discovery Destination Address" section, "Multicast Destination Address" is set to "LLDP Multicast".

As far as SNMP support of LLDP info is concerned, we have not supported LLDP-MIB till date.

Thanks for pointing this out. We will fix it in a future release.

Odd thats what i have the layer2 set to but its still not showing up...

Will be nice once the LLDP-MIB is supported, little by little you guys are getting towards standards :) ifHighSpeed, lldp sysName, and now maybe LLDP-MIB :)

@CSup wrote:

Odd thats what i have the layer2 set to but its still not showing up...

That's interesting. Can you please check if the LLDP "transmit" is enabled too, on the siwtchport.

LLDP Port Configuration:

Port Rx Tx SNMP --- Optional enabled transmit TLVs --
Mode Mode Notification LLDP 802.1 802.3 MED AvEx DCBX
19 Enabled Enabled -- -ND-- --- ---- ---- ---- --


Must say if LLDP-MIB was working this would be easier to troubleshoot :P

1 Like