Looks like man In the middle, but only on Cambium Wifi?

@Eric_Ozrelic
I tried to redirect things to other DNS servers. I tried to capture packets and force them…

Gave in an unplugged the 2 XV2-2 so the family would give me some piece and watch streaming service without complaining at me.

Running the Audience with the wave 2 drivers across 3 radios. (2.4 2x2, 5.0 2x2, 5.8 4x4)

Its 1/2 assed WiFi5 MU-MIMO… but its the “resolution” when you have inlaws over…

Family movie night required I turn off the XV2-2s. Spiderman purchase on Vudu required flipping wifi vendors.

Any updates coming?

Sorry man… this problem is so bizarre I doubt that you’re going to get an answer. I’ve worked with all of these devices… heck I have an XV2-2 in my home right now that I’m using with my LG TV and multiple streaming services, like Netflix, Plex, Amazon Prime, etc… no issues. The fact that certain movies work and some don’t… that your error msg’s pop up inexplicably in German sometimes… I mean… I don’t even know where to begin.

The DNS issue that we found during our remote debug session is targeted to be fixed in our 6.5 firmware release. I am hoping to have a 6.5 beta build available for you to try out in late April.

3 Likes

@GaryHans

Thanks for sticking with it.

1 Like

OH MY GOODNESS; I AM NOT ALONE!

The German connection problem warning had me curious. Video loading is sporadically surprisingly slow, but I figured I would deal with it some other day as we don’t stream much. This has been going on for two months or more - probably around the time I switched back to the XV2 in the house, or perhaps when we ran some firmware changes?

This happens on my Roku, but I haven’t cared enough to work on it. I only found this thread because someone mentioned a DNS issue in another forum, and I went looking.

I just ran a quick test. In the Roku, there is a main menu where you can choose your streaming platform. From clicking on “Prime” to the “Who’s watching” menu… takes 25 seconds on WiFi to the XV2 and includes the German warning!! I switched to wired and it only took 5 seconds and this warning never shows. The Roku is approximately 12 ft from the AP.

I have an XV3 here, so I tried that too. It also had the same problem. It takes 17 seconds until the German warning, and 8 more seconds until the Who’s Watching menu.

For fun - I connected to the E700 at the end of the house. It had the same problem.

These tests were done with firmware 6.4.0.1-r3.

Then, I downgraded the E700 to 4.2.1-r12 and the problem went away!

Anyhow, I’m glad that this will be resolved soon. I’ve been surprised at the amount of nuances associated with the cnPilot APs.

I upgraded to 6.4.1-r15. The problem remains.

1 Like

Had to bring in a WAX630E today.

Quirky thing with a slow interface. Long boot time. Can’t recognize 60 watt adapter or switch.

But…
Amazon and Vudu start right up.

My phone is connected to 6 Ghz too…

@Simon_King do you need additional troubleshooting information?

I’d really like to see this resolved and know v6 is working.

1 Like

I did a remote session a couple months back with Springs and found his issue to be related to a known DNS issue that we are fixing in our upcoming 6.4.2 firmware release. I can provide a 6.4.2 beta build once we have the fix.

@GaryHans I’m interested to know what sort of “DNS issue” would occur. Are DNS requests not being passed through the system?

What is Cambium doing in the AP other than passing on DNS requests?

The issue is related to the AP dropping DNS AAAA inquiries.

1 Like

Its driving me nuts too.

I am getting tired of telling my contracts, “JUST WAIT”.

Mean while… I have to fight off sales wanting to flip everything to UniF–k. Even though it would NOT BE ABLE TO PROVIDE THE SERVICES WE CURRENTLY DO…

Ruckus patched their problem that sent me to Cambium.
Anyone keeping score… 17 months it took to get a proper patch on that firmware.

Cambium is moving way faster… but… Ruckus and the Reps swore that the issue I was having with 2.4 devices staying connected in conference rooms “IS FIXED IN THIS FIRMWARE”.
It wasn’t

I went through a dozen or so iterations of “THIS IS THE FIXED FIRMWARE”.

17 months later I have stable connections…

We quoted a full Cambium Wi-Fi system for a customer of ours.

During construction, however, we have installed a spare UniFi Mesh-Pro for temporary service because we don’t want to end up with the cnPilot DNS issues biting us.

I had to build out an MDU back in March.

In the spec… “Each Unit Will have a Roku for TV services.”

That made that decision. Called up the distributor Monday to change manufactures. Did the whole install Thursday and the place has been running for ~6 weeks now.

1 Like

@Springs
In your DHCP server, what DNS address(es) are you passing to the Roku?

I’m doing some troubleshooting since I am hoping to find an answer soon.

If you have a unit setup for testing, please try setting your DHCP server to hand out 1.1.1.1 as the DNS server and see if your Amazon Prime App loads correctly.

I’d like to add some details:
As stated above by GaryHans, the AP is dropping DNS AAAA inquiries. It has been mentioned that the problem exists even without IPv6 enabled on a network. An IPv6 DNS inquiry can come from an IPv4 address, which is what occurs in this case.

This issue is made obvious with the Roku Amazon Prime App as it makes both an A and AAAA inquiry for every DNS lookup from an IPv4 address.

The mode of failure follows this structure:

  • Roku Prime App runs an A inquiry to primary DNS server and succeeds normally
  • Roku Prime App also runs an AAAA inquiry to primary DNS server
  • XV2 drops the AAAA inquiry
  • After timeout, Roku Prime App runs an AAAA inquiry on secondary DNS
  • XV2 passes the AAAA inquiry
  • AAAA inquiry succeeds

Stack this up multiple times, and the total time for several AAAA DNS timeouts adds up very quickly. This results in odd network connection timeouts.

I do not know the reason the XV2 is dropping the AAAA record requests, but I have found this:

XV2 Works
The XV2 DOES NOT drop AAAA requests if I set my MikroTik DNS server to pass out any of these addresses as the primary DNS address:

  • 1.1.1.1
  • 8.8.8.8

XV2 Does Not Work
The XV2 DOES drop AAAA requests if the primary DNS server is:

  • 9.9.9.9
  • 10.1.1.1 (Gateway address for MikroTik, but using 8.8.8.8 in the MikroTik)
  • 10.1.1.2 (Local BIND)

Short Version
So, I cannot run the MikroTik DNS proxy, or my own DNS, but I can successfully run the XV2 with 8.8.8.8 or 1.1.1.1 for my DNS server. This could explain why some people don’t see any problems, while others see regular problems.

Now, I also ran nslookup requests and did not see any dropped AAAA inquiries from any of the DNS servers, so there is still something missing to the explanation.

1 Like

@uberdome

During the call with Gary…
My Mikrotik was set to be the DNS server. With 1.1.1.1 set up as my DNS.
We changed that to 8.8.8.8
We changed it to 9.9.9.9
Then I used DHCP options to put those DNS servers on the Roku when it made a DHCP request.
Tried each one.

I tried trapping anything headed to 53 and dst-nating it back to 8.8.8.8

I have not bothered to do this all over again since the latest firmware. I had my router set up to use 9.9.9.9 when I busted out the XV2-2s to try the last firmware.

As we know DNS is set to be addressed in the June / July release… I packed everything up.

Yesterday I was bored and put the units back in place… All sorts of stuff started going wrong and I just didn’t have the interest anymore.

I got a message from Gary to check a few things and gave it a try today… Until my wifi calling stopped and I had to pull the WAPs to do my job.

I really don’t feel like messing with it until the next FIX.

I just have way too many hours into this at this point and have 6 other manufactures without the issues.

I can’t get Cambium WAPS, even if I wanted to put it in jobs. And let’s face it… If a customer was having these issues… It would be my A$$. So the XV2-2s are going back in the box until the next firmware from Cambium… And this mythical thing known as “free time” magically appears.

2 Likes