More template frustration.

I want to start out with a compliment. I complained more than anyone about the Force 100 dishes and I have to say that the Fore200 dishes are awesome and with the exception of not being able to assemble the mounting bracket as left handed I can't find anything to complain about really.  We haven't comparied its RF properties to the Force100s yet but I love the new design.

Now... the cambium UI with it's many annoying ticks and design flaws has one that right now frustrates me above all others.. You have managed to render templates almost useless...  I don't know about all the other WISPs out there but I don't have a lot of free time, actually I don't even know what free time is I've just heard people talk about it and it sounds like a nice thing.  I don't have all day to conifgure radios  so I like to spend as little time as possbile configuring all the radios for each days installs.  Useing templates normallyl make this a quick and painless process.  Not so with Cambium...  This is how my already rushed yesterday morning started out:

Setting up a 2.4Ghz Force200.  I just made a customer template for this POP and I created the template with one of the first Force200 radios we recevived so this should be quick and painless.

Upload the .bin config file   json error...  What !?! how is t his possilbe it came from another Force200 !?!  So log into an installed Force200 customer radio that is on this AP and download the config as a txt file.

Upload the txt file config  complains that the countrycode must be blank. Really ? WTF man!  So I edit the config which has "FA" in the contry code and per the error I make it blank.

Upload the txt file again  complains that the contry code is blank and requires  correct country code. 

I try FCC , to many characters,  I try FC , not a valid code, I try US  and it works .. almost

Upload txt config with country code fixed...  ERROR ! At this point I really just want to take a hammer to the radio...  so now it is complaining that the frequency scan list has invalid frequencies in it.  I find that setting and blank it out.  

Upload the txt file again OH that was  the 10Mhz list you cleared now it's the 20Mhz scan list !!@&*(!@#!@#~)(!~!!! 

SO blank ALL the scan lists in the config and FINALLY the template works.

Next radio , config fails because the ethernet port speed isnt' blank... blank it and it fails because it can't be empty... put in Auto.. yeah no... 100  now it's happy. Why was it 1000 the radio was set to auto ...


Hi Brubble1,

About your issue with Country Codes, I guess you have part of radios with FCC lock and other part areROW devices.

And some frequencies allowed for ROW device with OT country code are restricted for FCC locked devices with US Country Code.

About issue with port speed I will additionally check it but I believe that if you were trying to uplod config with 1000 Mbps port speed on Force 200 it would be uploaded properly without errors.

Could you please tell what FW version you have installed?

I will let you know.

Thank you.

I feel your pain.  I have gotten in the habit of configuring all radios on the bench first. I have a template json file for all three radio models (110, 180, 200) and after upgrading firmware on a new radio, I upload the correct config file to it and then change the IP address to the customers IP address.  

"I guess you have part of radios with FCC lock and other part are ROW devices.

And some frequencies allowed for ROW device with OT country code are restricted for FCC locked devices with US Country Code."

EDIT: (much removed after I discovered what FA stands for) As my message says, the country code it complained about has "FA" in it, which after some research it appears that mean "Follow AP" . The force200 the config was created on has an FCC sticker on it and the Force200 refusing the config has an FCC sticker on it. The radio refuses to accept "wirelessDeviceCountryCode": "FA" and you have to change it to "wirelessDeviceCountryCode": "US" it has nothing to do with the actual wrong country problem of Cambium restickering ROW radios with FCC stickers and then the configs from FCC radios failing because the ROW radio has to have "wirelessDeviceCountryCode": "" .

" I believe that if you were trying to upload config with 1000 Mbps port speed"

No, I was trying to upload a config with an AUTO Mbps port speed and Cambium puts "1000" in the port speed because it was created on a Force180 . Why is the AUTO setting being saved in the config as "1000" or "100" ? This means that a config from a force180 can't be uploaded to an ePMP1000 for no reason other than Cambium made it put "1000" in instead of allowing AUTO. And in turn if you upload a config from an ePMP1000 set to AUTO port speed will it make the Force180 default to 100Mbps ? Why ? 

If the source radio was set to force 1000Mbps then I could understand it when that config failed to work on a radio with 10/100 ports but it wasn't , it was set to AUTO...

"Could you please tell what FW version you have installed"

All of our customer radios currently run V2.5.1 and all new radios are updated to v2.5.1 when they come in. So the configs are created on a v2.5.1 radio and we are uploading them to v2.5.1 radios.

We are probably going to be upgrading everything to the new V2.6.1 soon , does it resolve some of these time consuming config problems ?

1 Like

Sorry for inconveniences with FCC and ROW devices mess.

About Ethernet port speed.

Auto is not allowed value for networkLanSpeed parameter.

Only 10/100/1000 values can be used.

If you want to use Auto-Negotiate on Ethernet port you should use networkLanAutoNegotiation with 1 value in txt config file.

"networkLanAutoNegotiation":    "1",
"networkLanSpeed":    "1000",

Thank you.


"Auto is not allowed value for networkLanSpeed parameter."

I know, that's the problem...  because of this  one little setting we have to maintain one set of configs for connectorized / integrated  ePMP radios and another set for force180 /200.  That's two sets of configs for for the 2.4 and the 5Ghz times the number of pops (or for some WISPs number of APs) .  So right now I have to maintain 48 separate configs and then double that again for ROW configs for each of them.  And I only have 12 POPs  , I can't imagine what kind of job it would be for large or even huge ISPs or even for anyone that wants to have a config for each AP  instead of just each POP.  

Unless the orginal connectorized and integrated ePMP radios are going to be rolling out with GigE ports like the rest of the ePMP line, which would render this problem solved,  why not make the firmware ignore "networkLanSpeed":    "1000" or "100" or "10"   if  "networkLanAutoNegotiation":  "1"    ?  Problem solved .   

Thank you.

You may use template with networkLanSpeed configured with 100 and networkLanAutoNegotiation with 1.

That configuration will be applied on every device.

1 Like

Fedor, I had assumed setting it to 100 would force the force180/force200 to 100Mbps so I was plesently surprised to find that when networkLanAutoNegotiation is set to 1  the radio ignores the networkLanSpeed configured with 100.

So I will use this in my templates as you suggest thanks.

However since the radios obviously ignore the networkLanSpeed when networkLanAutoNegotiation is set to 1 , that means the 10/100 epmp radios are refusing to accept a config because of a setting they are going to ignore anyway... so I still think that is broken and should be fixed.

Thanks again.

This is by design, but I agree that it can be improved. We will look into this.

Thank you.