On Premises CnMaestro Version 1.6.3-r15 declines Elevate 3.5.2 xm/xw Error: Unrecognized file

Dear Dev team & Members,

I was elevation my first litebeams m5 and all was well untill i onboarded two unit to cnmaestro. Elevate image softwares were still at 3.5.1 that did not support the letebeam m5. So when i onboarded the fisrt thing cnmaestro does is an automatic upgrade. Seems it uploaded the 3.5.1 and my two units died. I notice this was te case when i checked log and the units indicated they timed out in the process of upgrade. 
I have hence disable Automatic update after onboarding, i downloaded the xm&wm 3.5.2 tried to upload it on cnmaestrol but gives me a unrecognized file
I tried deleting the two 3.5.1 on cnmaestrol but would not let me do so untill i have uploaded other to replace them.

1. Is there a way i can recover the units
2. How do i upload the xm/xw3.5.2? so as i do not continue to loose more sms.
See below screen shot taken of the error.
You input will be appreciated so much

You need to upload the .tar.gz files, not the .bin files. 


Hello ricrealtek,

If the units are not responding, you will probably have to recover them using the UBNT Recovery procedure, as detailed here: https://help.ubnt.com/hc/en-us/articles/204911324-airMAX-How-to-reset-your-device-with-TFTP-firmware-recovery

Sorry for the trouble

I will try this when am in the office this morning.

Unfortunatetly once 3.5.1 is in the litebeams seems not to allow Tftp to the radio, then when it powers up it does two icp replies, four timeouts and the sequence is in that order. So not even access via browser or ssh to the unit.