PMP Login and Empty Password change in 21.0

Hey 450 Community,

So we’ve had 3 customers tripped up by this and even a couple people in Cambium (including my boss’s boss :slight_smile: ), so I thought I’d post here for others to be aware of.

Symptom: Upgraded to 21.0 or later and I can’t login to my 450 radio!
Scenario: 20.0 and you were logging in with admin and your secret password (maybe something tough to crack like “1234”) and it was working with no problems. Then you upgraded to 21.0 and tried admin/1234 and it isn’t working!
Root Cause: We enhanced the security on 21.0 and later software where if any login on the account does have a password configured, it no longer accepts logins from other accounts that are configured with no password.
Customer: But I was logging in fine in earlier releases!
Reality: There was no password on the device but you thought there was and there is a separate account with a password on your device.
Before 21.0, if you had admin/ and tried to login with admin/1234 it would give you the false positive that you typed in the right password but really you if you had typed in admin/blahBlahBlah it would have also let you in, because there was no password on the account, but you didn’t know about it, unless you tried with a bad password.

So if you can’t log into your account in 21.0, then there is another account configured on the radio that does contain a password.

We have now added a web page warning for this, so you can see after you login that there are empty password accounts.

Workarounds:

  • Figure out the username/password for the account that someone added on there. Ask around!
  • Use cnMaestro to downgrade to 20.3.1.2 and login into the blank password account left on there (i.e. admin/) and set the proper desired password
  • Use cnMaestro to upload a new password via config file load.
  • Default boot the device and change the password

Sorry for the inconvenience, hope this helps.

Charlie

4 Likes

Thanks for the heads up Charlie. Is there a cnMaestro or script Cambium can provide to help customers identify devices that have accounts with an empty password?