.pro email

Can we please have support for .pro domain added to the system please.


Did you try registering in cnMaestro with .Pro and dint receive any confirmation email ?

Correct. Tried multiple times.

Did you check your SPAM or junk folder ?

yes and our email server that is hosting our .pro also hosts our .pro and cnM sends emails to our .com just fine.

If you would like I can send you creds to your own .pro email on our server to investigate. 


Can you tell us exactly which page you are entering this email address on, and what happens when you submit the form? Are you getting an error message?

There are no registration requests in the https://support.cambiumnetworks.com/ database for .pro email addresses since April last year, so either your requests aren't being recorded in the database, or we are talking about different systems.

(cnMaestro uses https://support.cambiumnetworks.com/ for single-sign-on)



see image attached I just resubmitted the .pro email. 

@ the following link https://c18itaqnfx.cloud.cambiumnetworks.com/#/0/home-view/administrator

OK, thanks. We'll investigate further and get back to you.

OK I understand now, you are trying to invite .pro email into your account and you dont see any invitation email being sent. Is that Correct ?

yes sorry, as I look at my original post it is very vague nothing more confusing and frustrating.

Hi again,

We've found the problem. We tried to deliver an invitation on 2017/01/16 04:25 (UTC) but it bounced with "Recipient not found". Our mail provider keeps a record of hard bounces and refuses to attempt to deliver any more mail to that address until the bounce record has been cleared. I've cleared it now, so you should try to resend the invite.

Sorry for the confusion,


Its taken us this long to getting back around to trying to get this to work.

.pro email has recived the  invite link and is then sent to the login page, he then clicks register account and recives the error below after filling out the form.

Hello again. I'm very sorry, but this was an unrelated bug which temporarily broke the user registration form. It should now be fixed.

Please let us know if you have any other problems,