Problem with Canopy and database application

We are an existing user of Motorola Canopy. We are generally happy with it, but we are having problems when using it with the database application we purchased Canopy for.

We have three buildings connected to our main building with Canopy. The first we connected is using a different software application, and is having no problems. The second two buildings we connected are using an application called RecTrac, which is a sports facility management/point-of-sale system. RecTrac uses the Progress database.

When using the RecTrac locally, point-of-sale transactions are immediate. The same transaction will take 20-40 seconds when run across the Canopy network.

File transfer speeds across the Canopy are good, and Internet downloads are fast. I’m told that opening Excel files and graphics files can be slow across the Canopy network. We could probably live with that, but the RecTrac program is mainly why we bought Canopy, and the point-of-sale functions are so slow as to be unusable (20-40 seconds per transaction, when you have a line of customers, can be a LONG time!).

We purchased Canopy from a local dealer. They have been very good to work with, but I think they may be in over their head on this problem. They (and Vermont Systems, the RecTrac folks) have been very helpful in trying to resolve the problem, but we still have no solution.

Any help would be appreciated. Thank you.

Wade Dunham

As a follow-up, I installed Ethereal on the server this afternoon. We ran a sample transaction on the point-of-sale, and also copied a fairly large file from a workstation to the server. We saw a lot of “Checksum Incorrect” messages on both activities. Sometimes these would be every other packet, sometimes 3 or 4 in a row.

Maybe this will help diagnose the problem. Thanks.


Look at the Ethernet stats for errors in the Canopy.

We’re having a similar problem with our point of sale program.
One thing we tried that seemed to help was changing the AP downlink speed to 50 percent to get more throughput from the registers. Maybe the reduced latency with the new firmware will help.

jayt wrote:
...One thing we tried that seemed to help was changing the AP downlink speed to 50 percent to get more throughput from the registers....

Do you now have your Downlink Data set at 50%, and your High Priority Uplink Percentage at 50%? Thanks.


If reducing the error counts doesn’t help, maybe you should investiage how senstive your POS application is to latency? We run ancient AS/400 billing system over a network that is VERY sensitive to latency. This is because the application requires each tiny transfer of data to complete before the next one is sent.

For a test, you could connect to your application locally and insert a software network bridge in between with a variable amount of delay that you can control. Here’s a program that’s used for doing this sort of thing:
allthough, I have yet to try it myself.