Problems updating with CNUT

I have never used CNUT… I have been playing with it alot this week but I keep erroring out when I try to update a small canopy network i have set up inside the office.

The 5.2 Cyclone Omni is at 4.2.3 with boot 3.0

I give cnut the right password/snmp community string… it loads the right package (6.1 DES) yet nothing I do changes this error:

CANOPY61_DES.pkg loaded.
Starting Update Process…
Queue NE:my.ap.IP.addy for updating
DeviceStatus=Status:1;HOST:my.AP.IP.addy;ESN:;Message:Checking Network Element Status
DeviceStatus=Status:-1;HOST:my.ap.IP.addy;ESN:0A003E008CCA;Message:Cannot Determine Device Scheduler Information, Check SNMP Parameters
Update Process Has Completed

any Ideas what I am doing wrong?

The computer that you are using to run CNUT is on the same IP subnet as your radios, correct?

msmith- Yes. I have no problem at all accessing the AP or radios… they are all on the same network as well as subnet/IP range. I have even plugged the AP directly into the computer and get the same error.

Interesting. Is it the “latest and greatest” version of CNUT from Motorola? I have the older version, the one that was relesaed back in April/May. I used it to upgrade our whole network to 6.1. We are using all Non-Advantage products.

The new version of CNUT (I believe) has a tool which checks the scheduling version of devices (hardware or software) and upgrades Advantage AP’s to Hardware scheduling. It is supposed to do it in a synchronized manner to prevent SM’s from being stranded. If your AP is non-advantage I would recommend using the older version of CNUT if you can track it down. If you cannot, let me know and I will try to find my installation executable for you.

Did you check SNMP Parameters? I had same problems with some SM and I resovled the problem by setting the Accessing Subnet and Trap Address to 0.0.0.0.

msmith- what version/build number are you using?

CNUT Version 1.0

Build Number 1.00.r1

msmith- same version here

erkan- both accessing subnet and trap address are 0.0.0.0

msmith wrote:
CNUT Version 1.0

Build Number 1.00.r1


I'm using the same version and all but one of my units upgraded OK. I have a 5.7 BH that's giving me the same error. It appears that it took the FPGA fine, but will never go to 6.1. Btw, I get the same error about scheduling.

Very odd.

Dan

How long ago did you guys download this version of CNUT from Moto’s web site? I think I read somewhere that the newest version of CNUT is the same as the previous except the new one contains the tool to enable hardware scheduling on Advantage AP’s and SM’s at the proper time.

Maybe the newest version has some kind of bug in it? Contact me through private message if you want me to e-mail you a copy of the installation executable that I have.

It updated the AP… but now whenever I try to access the SMs that are attached to it it errors saying it cant login in to the SMs… I have input the right passord/snmp string (it is using the same as the parent element)

Any ideas?

When you try to login to the SM’s from where exactly? The SM’s should be auto discovered as LUIDs of the APs when a network refresh is done in CNUT. Then there is an option in CNUT to send the firmware for the SMs to the AP, and enable Auto Update so all the SMs connected to an AP will auto update themselves on behalf of the AP.

I don’t think I ever had to provide any input about the passwords for the SM’s. Let me know the exact steps you have done so far and the options you have set so I can try to narrow things down.

-Matt

you can provide specific password/snmp string info when you highlight the SMs (after you auto detect them with cnut) and clicking edit then going to modify current network element access. I have both put in the snmp string and the passwords… and left it default (using the parent element, the AP’s pass and string) and I continue to get the same cannot log in error.

the new error Im getting

Starting Update Process …
Queue NE:AP:[my.AP.IP.addy].LUID:[5] for updating
DeviceStatus=Status:1;HOST:AP:[my.AP.IP.addy].LUID:[5];ESN:0A003E0055A3;Message:Checking Network Element Status
DeviceStatus=Status:-1;HOST:AP:[my.AP.IP.addy].LUID:[5];ESN:0A003E0055A3;Message:Unable to communicate with Network Element (Possibly Connect/Login Failure)
Update process has completed

For the small wireless net I have set up I have 4 5.2 SMs all pointed at a cyclone omni in the center of the office. One SM is on 3.2.5, two are 4.2.1, and the one above (I tried updating it alone in this test… as it has the newest version) is 4.2.3.

accessing subnet and trap address are both 0.0.0.0… the snmp community string is the same as the ap… as well as the passwords, yet I continue to get this error.

any ideas?

Interesting indeed, I am having very similar problems, I cannot get CNUT to work for updates. even when I go in the field and connect directly to an sm, I cannot ftp to it using command line ftp, I have to use Cute FTP just to get into the radios. This is verry irataing, because I have appx 250 radios to update in the next 3 weeks, and I cant drive to each location and be doing these updates in person.
Anybody with any good ideas PLEASE REPLY
all ap’s & bh’s have been manually updated to 4.2.3, I want to get all SM’s in the field uptto 4.2.3 that aren’t already, before updating to anything newer.

While I’ve been off 4.2.3 foe awhile, I have always had the best luck by using CNUT to upgrade an AP and then using it to enable auto-update and have the AP send the files to the SM.

The way to do it is log into the SM, go to Advanced Network Configuration, in the Packet Filter Types uncheck SMB (Network Neighborhood), then click Save Changes then Reboot and try it again. This worked for me on the non-Advantage SMs.