Procedure to Add POP/DN/CN into E2E/cnMaestro on Prem

I have managed to create a POP and CN Link with th onboard controller by following the video…

I aslo managed to created an onPrem VM E2EController and integrate it into my onPrem cnMaestro successfully by reading several posts in this fourm.

Now I am stuck trying to add my first POP and start building links. I have not found any instructions that guide me beyond. I need to understand what basic configuration needs to be set in the POP inorder for it to communicate with the E2E Controller so that I can onboard it and then add links. I have added IPv4 addresses to both E2E Controller and the POP and they are both on the same physical network (no vlans) and I can ping the POP from the E2E Controller CLI yet I get no onboarding devices in cnMaestro/E2E Controller and if I manually add the MAC of the POP it still does not appear to make any communication.

I would love to read or watch a tutorial much like the previously quoted video that walks me through the entire process for the onPrem E2E Controller.

Does anyone know when I can find such a tutorial or can someone outline the process for me?

Sagar has created a video:

1 Like

So this video gets me half way there… it’s cnMaestro with OnBoard E2E Controller. I am using the on premise external E2E Controller.

After watching this video and trying again, I managed to get the POP connected to the External E2E Controller and I managed to get the LINK Created and established, but I do not have IPV4 connectivity to the CN and the CN is unable to communicate with the Controller.

I added the POP Site then added the POP Node via Mac Address in the controller.
Then I created the client site and added the CN NODE v1000 to the Client site via MAC Addrss in the controller.
Then I created the link using the POP and CN Nodes.
Next I manually set the IPV4 Adresses in both the POP and the CN.
I upgraded both to v1.1 firmware. and made sure GPS was disabled on the POP.
Powered it all up and managed to get the link to establish and I can ping the POP NODE from the WAN side and I can ping the CN NODE from the Ether side of the v1000 but I have no pass through i.e I can’t ping the POP NODE from the CN Side and I can’t ping the CN NODE form the WAN/POP side?

Any suggestions where I have gone wrong?

On the E2E controller, did you turn on Layer 2 Bridge? This will allow all IPv4 traffic to be tunneled through the mesh network.

Yes, it is enabled…

Does CN get onboarded to the controller (Is the CN shown green on cnMaestro) ?

If not, please check IPv6 routes on the controller. It can seen from Tools → Settings → Network Configuration section in cnMaestro. Is the E2E controller in the same IPv6 subnet or L2 domain as POP ? If yes, default route pointing to POP IPv6 address will do.

Can you please let us know if ‘Disable Broadcast’ flag on POP is unchecked like below?


The CN needs to show green on the cnMaestro.

No, the CN does not get onboarded. Link is Green but CN is red in cnMaestro.

There are no routes for IPV6 listed. Yes, the E2EController is in the same IPV6 subnet as the POP. Layer 2 Bridge DISABLE BROADCAST is not checked as per your example.

Can you give me an example of what a default Route would look like?

fd00:ba5e:a9bc:225e::4:5688:4100 is the POP IPV6 address assigned bu the E2EController.

For IPv6 route to be configured proper on the POP node, you should download the config file from the cnMaestro (when you add the POP, you will be prompt), and upload this config file to the POP. This will get your network all configured properly.

I had already done this before it onboarded. Just tried again to download and import to the POP. No change. Rebooted POP and waited a while, but no joy. CN still not reachable. I have also tried factory reset on the CN and re-configured with quickstart and IPV4 addressing.

can you try rebooting the E2E controller?

The IPv4 address of the CN shall be configured on the E2E controller, not the CN.

Rebooted the E2EController with no success.

Made a factory reset of the v1000 CN and made no changes to any setting. Link is established but no access to CN in cnMaestro and no IPV4 connection or L2 Tunnel

CnWave implements a centralized configuration management architecture. The E2E controller serves as the point of truth for all node configurations, and is responsible for keeping all nodes’ local copies in sync with its own view. All config changes are applied using the controller.

Any changes done directly on the node get overridden when node connects to the controller. So, the configuration should be updated at E2E (or cnMaestro).

About the route, please type default in the Destination field.

Tried to add a Default route and got the following error when opening the Settings page

And this one when adding the Default and pressing the Save button…

Also noticed I get this error when selecting the Services page… is not an IP I’ve entered anywhere or one that I use?

There is no need to set default GW if the POP and the E2E are in the same subnet. Can you please download the diag files from the POP and the CN and send to me?

Here you go. Let me know if you need anything else.

Thanks, can you also download the e2e_controller file? from cnMaestro, click on the E2E controller under the network list, go to tool, then diagnostic…

Attempted download but no file is generated? Tried in Chrome and Edge.