PTP450i Not Passing traffic

I Replaced a PTP450i Slave module that was taken out by lightning. The new module is a Version 15.0.3 and the Master at the other end is a 14.1.1. The new module registers fine and I have a good RF link, around  -48 Received Signal Strength and 100% link tests with approx 11.3 Mbps downlink and uplink in both directions at 5Mhz bandwidth, which agrees with linkplanner for the distance of the link. But with the new slave installed I am passing no traffic through.

I can access both modules web  browser and ping both modules with a laptop at either end of the link but the laptops cannot see each other even though they are on the same subnet as each other and both PTP450 modules. 

I noticed new feature screens of Port configuration and protocol filtering on the 15.0.3 module. They are set at default. Am I missing something. I use this link to pass Digital ROIP modem traffic and it worked well when both the Master and the Slave were 14.1.1. I am not using DHCP and there is not Default Gateway for the subnet, just switches at both end connecting the VIP modems. But even directly connected to the POE power supply with my laptops I cannot ping the laptop at the other end.????

I'd first off make sure both ends are running 15.1.1. Second, in the Tools section of each radio there's a ping test. Try to use this ping test on both the slave and the master to ping either side. Then, make sure your laptop that's plugged in is in the same subnet as the radios, try to use the ping test to the laptops IP. You might need to turn off your firewall or security on the laptop to get pings to respond.

Windows 10 firewall is now blocking ICMP traffic. Not saying that is the problem here but thought I'd mention it since it messed me up for 15-20 minutes.  You have to enable it now in Windows firewall rules.  

Hi Eric and Nathan,

Thank you for your reply. The laptops are on the same subnet as the radios and it is doesn't seem to be a windows firewall issue because I have two other links with this customer identical to this one except that both the masters and slaves are version 14.1.1 on those links. Traffic passes fine on those links (they act like a bridge is supposed to) and I have tested pings from end to end with the same two laptops.

On the link I am having problems with neither pings nor traffic passes thru from end to end but both radios respond to pings from either laptop and I can open the GUI of either radio from either laptop. I can run link tests from either end and the RF link is running great. I have not tried the radios ping utility but I am sure it would work pinging the other radio. So it seems as if this link is just not acting like a bridge, but only responding to traffic addressed to them. I am hoping to get a response from a cambium tech or someone who has experienced this on what might be causing this. 

My Customer is a Police Dept and they have one of their voter receivers down because of this.

Thanks again,