R201P keeps dropping wifi


       I have a Cambium R201P. Firmware version 4.0-R2. This has generally been working flawlessly but during the last week, wifi has been dropping out randomly. Any device connected via ethernet continues to work with no disruption to throughput. Generally one of the following things happen.

1. Either the 2.4 or 5ghz wifi drops out or both & the SSID can no longer be found. Wifi Analyser will not find the SSID nor removing the saved network and searching for it again

2. The SSID's can be found but there is no throughput. Cannot connect to anything.

To remedy this using the web interface turning AP off then back on for both wifi networks gets it going in most cases. Worse case the router itself has to be turned off for a minute then back on. No settings have been changed to result in this.


I was going to attempt a factory reset but thought a Firmware update might be better. I am thinking up updating the firmware might help but not sure if I can update to the latest version because of this from the Firmware download page:
Due to a newer flash memory layout used in 4.3 firmware including 4.3.2, upgrades from older versions prior to Release 4.3 need to be done TWICE while upgrading from the UI of cnPilot R200/201.  After the first time upgrade, the user will see a message “(Firmware Check Error. Please Upgrade Again!!) ”in the login page of the device

If I back up my settings, will I be able to update the firmware to the latsest version? Any suggestions as to why all of a sudden the wifi would be dropping out?

I have done a hard factory reset & updated the firmware to 4.3.2-R4 and set everything up fresh. Will monitor how it goes.

1 Like

Hello, The factory reset and firmware update have made no difference. So tonight I have arrived home from work and my android phone connected to the 5ghz wifi and was working fine.

My wife has a windows 10 laptop and it only shows the 2.4 ghz SSID. It connects to it but has no throughput. We rebooted the laptop several times and removed remembered wifi's from the settings. My wife also has an iphone and it also cannot see the 5ghz SSID but will connect to 2.4 but has no throughput, so we rebooted the modem.

On reboot, my android phone connected to the 5ghz SSID but I had no throughput. I switched my phone to 2.4 ghz SSID and it worked fine. I then switched it back to 5ghz and it works fine.

The windows 10 laptop could only see the 2.4ghz SSID (yes it is 5ghz capable) and would connect, but no throughput.  Tried this on my wife's iphone and it can only see 2.4ghs SSID with no throughput, same as the laptop.

This hit and miss wifi is frustrating to say the least. Any suggestions from anyone in the Cambium community. At this point I am going to buy another brand router and POE injector and use the Cambium as a speed bump.

Please send  device configuration  and syslog message  to email id : niraj.mahapatra@cambiumnetworks.com. We will get back  to you after  investigating this issue.

Files emailed as requested. Thank you.


We loaded your config file, we didn't see the issue with iphone or Windows 10 laptop with 2.4G radio.  We are investigating the setup to reproduce the issue.

Can you please try changing the channel bandwidth from 20/40 Mhz to 20 Mhz on 2.4G radio and check your iphone /windows 10 laptop is getting throughput. Please update on this.

Check screenshot attached.

Hi Divikar,

                I have changed the setting as requested and will see how it goes this evening. But that still doesn't explain why the 5ghz SSID is sometimes lost alltogether. Last night when we got home, both my android phone and my wifes iphone connected to 5ghz with no issues. However, a western digital media player we have (only has 2.4) would connect but had no throughput. It seems to be very random as to when it happens and I am having trouble finding a reason why.
I'll see how things go tonight.

I will list the items we have in our home tht are connected and the method they are connected if that may provide some assistance:

 Wifi: 1 x android phone and 1 x android tablet. Normally connect to 5ghz but sometimes switch to 2.4 when at the far end of the house. 3 x Apple iphones. 1 x Western Digital Media player, 1 x Xbox 360 and 1 x Xbox one. 1 x Samsung Smart TV. 2 x Windows 10 laptops and 1 x Windows 10 tablet.

Ethernet: 1 x NAS server, 1 x Windows 10 PC, 3 x Fetch TV set top boxes. 1 x LG smart TV and 1 x Hisense Smart TV. 1 x Sony Bluray player.

We have a dual occupancy home so as you can see we have a large number of devices. Note, some of the ethernet connected devices run through a small TP link switch. I am wondering if the router is up to the task with so many devices connected?

Thanks Brian

OK, I just rebooted the router after making the changes you requested. My android phone connected to 5ghz but I had no throughput. Speedtest shows network communication issues. I switched the wifi on my Android phone to connect to the 2.4 ghz and it worked. I then swicthed back to 5ghz and I had throughput.

I had my daughter test 5 ghz on her iphone and she had no throughput. Switched the iphone to 2.4 and it worked. Switched the iphone back to 5 ghz and it also has throughput. I have emailed the system logs since the reboot through. 

I have a cambium E400 and I'm getting a similar issue with just Iphones  dropping out. I'm assuming the 5ghz is droppping because it fluctates and I mainly see the  2.4 ghz. Both AP are using 3.3-r16 firmware. I also have no prefer DFS channels. Could I send in an event log as well.

Just a heads up coolguy, I haven't heard back from Cambium since sending my last lot of logs to them so at this stage have no fix. I'll post if I hear anything.

Sorry for the delay in response.

As per syslog message . WAN IP  of R201 is  renewed  every 1 hour interval.  In this cases ,you may not get internet for few seconds .

Please ask your ISP to increase DHCP Lease time(24 Hrs Durations) for  your R201 device.

Please send the tech support logs of E400  to further investigate this issue  and arrange a remote session to analyse this issue.

Syslog Message.

<Mon Jul 10 17:54:20 2017> kernel: Wireless: Rcv DIS-ASSOC From 9c:f4:8e:57:8d:46

<Mon Jul 10 17:56:34 2017> udhcpc[5135]: Sending renew...

<Mon Jul 10 17:56:34 2017> udhcpc[5135]: Lease of obtained, lease time 3600

<Mon Jul 10 17:56:43 2017> udhcpc[5543]: Sending renew...

<Mon Jul 10 17:56:43 2017> udhcpc[5543]: Lease of obtained, lease time 3600

<Mon Jul 10 17:57:08 2017> provision[18366]: start to check config file

<Mon Jul 10 17:57:08 2017> provision[18366]: Update configuration fialed, retry 3600 s later

<Mon Jul 10 17:58:05 2017> DEV_MANAGER[18624]: Not able to find [ device_id ] in keystore

<Mon Jul 10 17:58:09 2017> DEV_MANAGER[18624]: Error response: [{"error":{"level":"error","message":...

<Mon Jul 10 17:58:09 2017> DEV_MANAGER[18624]: Unable to discover cnMaestro URL (re-discover in 327 ...

<Mon Jul 10 17:58:09 2017> DEV_MANAGER[18624]: Attempting (re)connection in 5 minutes

<Mon Jul 10 18:01:47 2017> udhcpd[10928]: Sending OFFER of

<Mon Jul 10 18:01:47 2017> udhcpd[10928]: Sending ACK to

<Mon Jul 10 18:03:38 2017> DEV_MANAGER[18624]: Not able to find [ device_id ] in keystore






<Mon Jul 10 18:03:42 2017> DEV_MANAGER[18624]: Error response: [{"error":{"level":"error","message":...

<Mon Jul 10 18:26:28 2017> DEV_MANAGER[18624]: Unable to discover cnMaestro URL (re-discover in 339 ...

<Mon Jul 10 18:26:28 2017> DEV_MANAGER[18624]: Attempting (re)connection in 5 minutes

<Mon Jul 10 18:26:34 2017> udhcpc[5135]: Sending renew...

<Mon Jul 10 18:26:34 2017> udhcpc[5135]: Lease of obtained, lease time 3600

<Mon Jul 10 18:26:44 2017> udhcpc[5543]: Sending renew...

<Mon Jul 10 18:26:44 2017> udhcpc[5543]: Lease of obtained, lease time 3600


Sorry, but I fail to see how my ISP increasing the DHCP lease time will reslove a wifi SSID not showing as available, or working on one device and not another at the same time. The short lease time in theory should affect all devices one my network at the same time and not result in the SSID's not being visable or affecting random devices.

I also do not think my ISP would change their settings as it would affect not only me but all their clients. I assume they have their system set this way for a reason. Next suggestion?


We are doing longevity test in our lab setup over the weekend with your config, to replicate the issue. We will update. 

Try using firmware version 4.3.2-R2; Don't use v 4.3.2-R4 its not stable

As part of the testing, reboot the modem and see if wifi devices connect straight up again. Or leave wifi range and return to see if the SSID's are showing or if devices connect again.

With longevity test also, we were not able to replicate the issue.
Can you please arrange for a remote session, our testing and dev team will look at your setup for debugging the issue.

With all due respect, sorry, but I will not be organising a remote session for anyone to access my internal network. I'll make arrangements to work through the issues some other way with my ISP. 

Yes, same problem experiencing here. I am fed of all of this wifi dropping problem especially on weekends. I use sony bravia smart tv set. But this problem has made all of this a mess. I can use Kodi tv without it. Please solve it ASAP.

Sorry to say that 201p its a f**** mess. I have another boxes that will go to trash when 4.4.2R2 becomes old. Because 4.4.2R2 it's the only firmware we can properly work. Do not forget to use Basic Mode and Update twice.

Buuut, if you have an ethernet connected we have found many users that get internet completely off by simply having some ethernet errors. (Yes wifi goes off too)

We found that those messages comes with some (at leas 25% ) CPU usage.

Dont know what to do. Unable to debug, and if you find one they will tell you to upgrade the device.

The same problem with wifi it's a lot of lost packets and desconections, there will be a bugfix becaus we have more than 200 routers Online with problems.