Random Reboot 2.6.1

Hello All,

I have been holding off jumping on the 3.0 ship, so I have a new issue pertaining to 2.6.1

Two receivers within 15 minutes of each other rebooted.

They are both setup in ptp meaning I had TWO ptp links have their receiver reboot.

Not using DFS Channels

No loss of power, checked all the other devices. (plus battery backups are present)

The odd part is the system uptime timer has started over but my switch never shows the port changing from 1gig.

So, Now What? 


Found this with the debug command.

<3>Assertion failed! rx_status->min_snr != 0x80:ath_rx_process /home/builder/jenkins/workspace/Avenger-Release/backfire_lsdk/package/at-aquila/drivers/wlan/os/linux/../../lmac/ath_dev/ath_recv.c:1371
<4>Call Trace:
<4>[<8024ac04>] dump_stack+0x8/0x34
<4>[<c0a33bac>] ath_rx_process+0x850/0x8d8 [ath_dev]
<4>[<c0a45440>] ath_rx_bf_handler+0xd48/0x10f4 [ath_dev]
<0>Kernel panic - not syncing: Take care of the assert first

We are already working on that issue to provide fix as soon as possible.

Sorry for inconveniences.

Thank you.

k, thank you for the fast reply didn't know if this issue might have been something fixed in 3.0.

If you could provide some finer details that would be great,

Is this just affecting GPS units? 

Is there a way to slow down the period of time in reboots or is it completely random?

Issue should be fixed in 3.1 Release which will be available soon.

Both GPS and non-GPS units are affected.

I would be really appreciate it if you could provide more information from your side:

1. What is RSSI and SNR levels in both directions?

2. Is used channel clean or not?

Thank you.

Link One -


Distance 7.451

Reading @ AP: RSSI -63 SNR 33

Reading @ SM: RSSI  -61 SNR 34

Link Two -


Distance 2.235

Reading @ AP: RSSI -61 SNR 36

Reading @ SM: RSSI  -66 SNR 31

There are other 5ghz units on the tower but with 10-20mhz channel separation

Yeah, I'm pretty sure these are bugs with ePTP mode that have been resolved in newer 3.0+ firmware revisions.

I am having the same issue with a PTP link. Where can I get the firmware to fix this?

@pkats wrote:

I am having the same issue with a PTP link. Where can I get the firmware to fix this?

Just go to the Cambium ePMP downloads area (you might have to login with your cambium account), and download the 3.0.1. firmware. Keep in mind this MIGHT fix your issues, if it doesn't, you'll have to temporarily use TDD-PTP mode. If it doesn't fix your issue, you should file a ticket with Cambium support. I know that Cambium's working on another update that fixes some other ePTP issues ATM... but these issues are pretty rare.

I updated to the new firmware but still have the problem. Tried two different radios one was better than the other but still has the problem. Tried different power supplied and still the same. Anyone found a fix yet.

Hello, I also had the same problem with ePTP to update to firmware 3.0.1 decreased the restarts from minutes to hours, but was only solved problems 100% when set the link for TDD PTP. Tip from our friend Eric, thanks .....

Checking to see if this issue was resolved in 3.1