Setup LACP Port Channel with different config

I need to setup an LACP port channel with a slightly different config than what I’m able to acheive in the XMS-C platform. Once configured following the guidance here for XMS-C, I need to access the web interface and remove the port members and re-add them with mode set to “Manual” to work properly with our 3rd party switch. Is there a way I can acheive this with XMS-C?

I need the ports to look like the following, set to Manual & Passive

I currently achevie this by re-adding the ports with the mode set to Manual in the WebGUI:

To acheive this natively in the XMS-C platform, I think I need to create a unique profile, just for this switch and under Profile > Configuration > Optimization > Snippet > append the following under “Switch Commands”:

config terminal
interface port-channel 1
switchport mode trunk
mtu 9216
no shut
interface extreme-ethernet 0/3
channel-group 1 mode on
interface extreme-ethernet 0/4
channel-group 1 mode on
exit
exit
copy running-config startup-config

Can someone cofirm the above code snippet is what’s required to set the LACP port channel to Manual to acheive this from XMS-C and it should be set in the profile, as outlined above?

It’s not clear whether I need to include the 2 x exit commands as well as the final “copy running-config startup-config” command

Hi Jon, please use the below XMS-C profile switch snippet.

!
interface port-channel 1
mtu 9216
no shutdown
!
interface extreme-ethernet 0/3
channel-group 1 mode on
!
interface extreme-ethernet 0/4
channel-group 1 mode on
!
1 Like

Hi Gary, thanks for the pointer - all working as expected :slight_smile:

I added in switchport mode trunk just under interface port-channel 1 as it keeps setting to Hybrid and not working otherwise.

Can you clarify what the ! does in the code? Is there a reference guide on the snippet CLI and what needs to be included/excluded?

I only ask as in this post, it shows config-terminal and end is included. How do you know when/what to include or exclude?

Hi Jon, there is no need to include “config t” to access the global config mode as XMS-Cloud does that for you. The ! takes you back to the global config mode. Also, there is no need to 'copy running-config startup-config" as XMS-Cloud also does that for you to save the switch configuration.

For a listing of all the switch the configuration parameters, you can log into support.cambiumnetworks.com and go to https://support.cambiumnetworks.com/file/12efd43bd239bc70b750bbf4e5a369db15ecac2d to access the PDF with this information. It can also be useful to run the “show running-config” command from XMS-Cloud or SSH to see the CLI command structure.

1 Like

Just to quick update to highlight if anyone is having problems issueing DHCP across your newly created port channel setup via XMS-C CLI Snippet, even if you enable “Port Security Trusted” in the port via the XMS-C GUI, you must have it in the cli snippet in XMS-C to take affect as anything set in the XMS-C GUI is overwritten by the cli snippet.

As DHCP Snooping is enabled by default, you need to specifically set “ip dhcp snooping trust” on the “interface port-channel 1” you’ve created so that DHCP requests can be resolved accordingly across your switches.

Our XMS-C CLI Snippet is now the following:

!
interface port-channel 1
switchport mode trunk
mtu 1500
no shutdown
ip dhcp snooping trust
!
interface extreme-ethernet 0/3
channel-group 1 mode on
!
interface extreme-ethernet 0/4
channel-group 1 mode on
!

Any further changes to the Port Channel must therefore be held within this XMS-C CLI Snippet.

Took a while to realise this as the XMS-C GUI doesn’t reflect what’s set in the CLI Snippet so it got missed initially until you realise in the local switch GUI it isn’t on. We could have statically assigned IP’s which all worked over the link, just not automatic DHCP.

I hope this helps others remedy their config too.

1 Like

Thanks for posting @Jon_McNamara . For others, I just wanted to clarify that this is for the cnMatrix switches.