SM won't kick in update


We have updated the whole network to new version 6.1 everythign went fine, but only one SM will not update. It still on 42.3. All the other SM’s in the same AP have updated just fine.

All the settings are same. Tried to reboot, left the Auto update on AP for 3-4 days but no responce.

Can anybody help ? what to do next …

I’m having the same problem. I have never been able to use CNUT in full since half of the 85 SM’s do not take the update. After doing several test I’ve come to the conclusion that the SM’s which web page is locked up will not take the update until you reboot them. Other SM’s will not take it at all. The other thing I’ve tried it using the 42actionlist_DES.txt file from release 4.2 and modified the content with the new fpga file name and enabled autoupdate manually on each AP. That seemed to work for most of the SM’s. However I was left with 5 SM’s which wouldn’t take the update no matter what and I had to do those manually. In case you wonder where can you get release 6.1 files for manual upgrade, enable autoupdate on one AP using CNUT and then login to the AP using FTP and use the GET command to download those files to your computer.

I have had the same problem with a number of SM’s in the past few days. It seems that the SM’s will not repspond to CNUT when they are autodetected through the AP’s. I have to manually add them to the network root and then do the update - works fine then. Just a PITA to add the IP’smanually (was also able to cut and paste from a previous list).


Have had the same problem. Tried one of the above methods, putting the SM in the root network and directly updating it. That worked on 2 of the problem SMs, but did not work on the other one. Was wondering about the manual update that you guys tried. I retrieved the files from the AP using FTP, and everything makes sense, but the FPGA file is called “TEST_51104_D40A.jbi”. This is different than the previous FPGA files, and was curious if the ftp/telnet commands are the same? Is this the correct file name? would the telnet command still be “jbi -aprogram TEST_51104_D40A.jbi” ? Any help would be great.

I know you dudes have done this, right? Just needed to know the telnet commands to make sure this works before I attempt it. Specifically, do you follow the same directions for manually updating a module to 6.1 like you would on the previous firmware? I still have some modules that are being a pain, and not taking the update no matter what I have tried.

i have two comments:

first, my initial install of the CNUT several months ago, when it was first released, would not auto-detect properly. actually none of my SMs would show up auto-detected. when taking on the 6.1 upgrade i first uninstalled the CNUT and installed a fresh copy from the download section. it’s the same version of the CNUT, but this time the new install has auto-detected all of my SMs and completed a full 6.1 upgrade with no problem. i’m not sure if the CNUT package was changed or not, but that’s my assumption.

second, if you’re getting the “webpage” errors on any devices (where the webpage of the radio is not responding without a reboot) then i’m thinking you have your antennas on public IPs. This is not a good idea for your network structure. Motorola has not yet fixed the error that causes the webpages to stop responding, but since i’ve changed my network to use private, non-routable IPs for all radios i haven’t lost any of the webpages. with public IPs i was losing them every day, with private IPs i haven’t lost a webpage in over 6 months. i don’t know if you have public IPs in the radios, but there’s really no reason to do so, and it can actually become a problem, not to mention wasting valuable IPs.

well, thanks, but none of that helps. I dont use public IPs and have a new install of CNUT.

if only one or two SMs aren’t updating properly try selecting them in the CNUT and then performing “Update Selected Network Elements” to just upgrade that one antenna.

i’m throwing out ideas, brainstorming, hope it helps.

I appreciate your input. I have done all of that. I really just need some input on manually updating the module. I know some people have done this, and would like to know some details of it all.

Still have just one that will not update, i have rolled back its firmware and then tried it, did not work. Have added it to root, then directly updated it, did not work (even though CNUT said that it completed the update). Have enabled autoupdate on AP several times, did not work. Only thing I have not tried is a manual update, and noone has posted how to do that yet.

This module had an FPGA version of 07??? something, which i have never seen before, wondering if that has something to do with it.

anyone? Bueller?